Spiker
Enthusiast
Enthusiast

Rolling failover with Nic teaming

Just a quick question

By default rolling failover on VSwitch NIC teaming policy set to NO by default which means it will fail back when recovered.

Is this a sensible default ? - with an intermitent ethernet connection due to problems with the cabling would cause the cards to flip flop so would it not have made more sense for the default to have been YES - in other words stay failed over

Any thougths ?

0 Kudos
5 Replies
ZMkenzie
Enthusiast
Enthusiast

Basically, yes, if you have flip flop problems then you should set it to YES, failover is not lossless, usually it takes 3-4 seconds to swap port, it usually loose 2 icmp pings if you test it, so i won't suggest you to keep the default if you are SURE that your network connection could act in this way.

pcomo
Enthusiast
Enthusiast

HI,

Could explain me the difference between Active/Active Nic and Active/stanby Nic.

Rolling is for which policy?

Thanks.

0 Kudos
depping
Leadership
Leadership

Active / Active can best be used for the VM portgroup, loadbalanced on virtual port id.

Rolling is more for the Service Console / VMkernel. Setting it to No, causes a failback. Setting it to yes pins it unto the new nic until it needs to failover again.

I would set it to Yes if you have 2 dedicated nics for the Service console port group and 2 dedicated nics for the VMkernel portgroup.

By the way they changed the term to "failback" in 3.5 and when set to "Yes" it failsback and when set to "no" it doesn't... makes a lot more sense doesn't it.

Duncan

My virtualisation blog:

0 Kudos
pcomo
Enthusiast
Enthusiast

Hi, Thanks for your fast answer.

We actually encoutered a strange problem in our customer site.

First, it seems (network guy told us) that physical switch is correctly configured for Spanning tree and PortFast mode.

We configured VM portgroup with Three pNics (teamed) Active/Active/Active and we tested failover,we lost VM network connexion when we re-plug cable. It seems that we lost it when the failover policy failback to the prefered pnic.

Do you think that if we set Rolling to NO that this symptom can be resolved?

Or do you think that we need to put one pnic Active and the other two in standby?

And finally do you think that three pnic is recommended or two pnic is more correct?

Thanks.

0 Kudos
1putt1der
Contributor
Contributor

HI did you ever get this issue resolved. I am having the same issue.

0 Kudos