VM_appliance
Contributor
Contributor

Performance issue in esx 3.5

Hello everyone,

I have 2 VMware ESX 3.5 server with each having 2 instances running rhel5.3 OS. Instances are named as instance1,instance2 in Vmserver 1 and instance3 and instance4 in vmserver 2. I have my own AAA applicaiton running on top of all 4 instances. Each instance has 2 virtaul cpu and 4GB of memory and a virtual nic is assigned for each instance (ie each vmserver has 2 physical nic, and the two instances are virtully using the same nic). I will be testing by sending the packet from vmserver2-instance3 to vmserver1-instance1. the network communication is good and the perforamnce of my server is as expected. But the problem is when my vmserver2-instance4 communicates with vmserver1-instance2, the communication is too poor and there is huge delay and my performance is too low getting only 1/3rd of the performance. note,,this is the only instance which is sending the packets and no other instance is simultaneously sendig the packets. is this something related to virtual NIC or did i miss anything here???

vmserver1

Inst1 Inst2

vmserver2

Inst3 Inst4

the performance is good and its as expected when inst3 communicates with Inst1, but there is very poor performance when Inst4 communicates with inst2. note.all the instances are sharing a physical NIC in each vmserver. note i m not simultaneously using both the instance 3 and 4 to send packets, but only one at a time.

I have stopeed the iptables and chkconfig iptables,but still i could not figure out whr the problem is ... any config issues ,pls help

Tags (1)
0 Kudos
3 Replies
Amievil
Enthusiast
Enthusiast

The vm's are runnig in physical disk?

If yes, try execute this command:

dd if=/dev/zero of=testfile bs=1M count=1024

And post the results here.

which is the manufacturer of your server?

Julio, ______ If you found this information useful, please consider awarding points (Correct or Helpful).
0 Kudos
VM_appliance
Contributor
Contributor

yes, both vmserver 1 and 2 is running in physical disk,

pls note the communication/erforamnce between inst3 and 1 is as expected,only having issue with the below instances.

here is the output from both the instance ie 2 and 4:

-


inst 2 output------

# dd if=/dev/zero of=testfile bs=1M count=1024

1024+0 records in

1024+0 records out

1073741824 bytes (1.1 GB) copied, 32.7247 seconds, 32.8 MB/s

#

-


inst4 output------

# dd if=/dev/zero of=testfile bs=1M count=1024

1024+0 records in

1024+0 records out

1073741824 bytes (1.1 GB) copied, 36.9949 seconds, 29.0 MB/s

#

Both the servers are HP Proliant

0 Kudos
Texiwill
Leadership
Leadership

Hello,

Moved to ESX 3.5 forum.


Best regards,

Edward L. Haletky VMware Communities User Moderator, VMware vExpert 2009, Virtualization Practice Analyst[/url]
Now Available: 'VMware vSphere(TM) and Virtual Infrastructure Security: Securing the Virtual Environment'[/url]
Also available 'VMWare ESX Server in the Enterprise'[/url]
[url=http://www.astroarch.com/wiki/index.php/Blog_Roll]SearchVMware Pro[/url]|Blue Gears[/url]|Top Virtualization Security Links[/url]|Virtualization Security Round Table Podcast[/url]

--
Edward L. Haletky
vExpert XIII: 2009-2021,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos