VMware Cloud Community
awinkel
Contributor
Contributor

Paths from datastore changes every second

I've three ESX (3.5) servers connected to sanswitches which are connected to an eva3000.

The performance is very low and the /var/log/vmkwarning file is filled with SCSI errors.

The error is:

Apr 9 17:16:14 esxhelm01 vmkernel: 0:23:41:52.109 cpu2:1056)WARNING: SCSI: 4567: Manual switchover to vmhba1:0:2 completed successfully.

Apr 9 17:16:14 esxhelm01 vmkernel: 0:23:41:52.361 cpu3:1057)WARNING: SCSI: 4526: Manual switchover to path vmhba1:1:2 begins.

Apr 9 17:16:14 esxhelm01 vmkernel: 0:23:41:52.601 cpu3:1057)WARNING: SCSI: 4567: Manual switchover to vmhba1:1:2 completed successfully.

Apr 9 17:16:14 esxhelm01 vmkernel: 0:23:41:52.827 cpu3:1055)WARNING: SCSI: 4526: Manual switchover to path vmhba1:1:2 begins.

and this repeated every second... Smiley Sad

When I look at the properties of the datastore (see attachment) and I press "Refresh" I can see that the path who is active changes every time.

Does anyone recognize this and/of knows a solution for it? Smiley Happy

Reply
0 Kudos
9 Replies
kukacz
Enthusiast
Enthusiast

Maybe you are using wrong multipath policy, perhaps the "fixed" one. Try switching it to Most Recently Used (MRU) at datastore properties.

--

Lukas Kubin

Reply
0 Kudos
mike_laspina
Champion
Champion

Hi,

You are observing what is called thrashing.

What is you multipath policy set to on other hosts MRU or fixed? MRU is the default.

Issue the following command at the console.

esxcfg-mpath -l

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
mike_laspina
Champion
Champion

I believe the HP EVA3000 is an active/active configuration and is more suited to fixed policy.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
awinkel
Contributor
Contributor

I'm using MRU because our EVA3000 has firmware v3.11 so that it works as a passive-passive array.

After firmware V4.xx it's acting as an active-active array.

I experimented with the fixed setting, but that didn't help.

Reply
0 Kudos
mike_laspina
Champion
Champion

MRU is correct for an active/passive SP.

Since it is thrashing you will need to find the failing path or external cause of it. Start with looking for a misconfigured zone of the fabric it's the most common reason.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
awinkel
Contributor
Contributor

I've just checked the zoneconfig in our sanswitches but everything seems just fine.

The three ESX servers have each one fabric and they are all in the same zone including two other ports for the backupdevices.

The errors only shows up in the logfile of the server when that server runs a virtual server which is placed on the eva.

Reply
0 Kudos
awinkel
Contributor
Contributor

I've found more information!

When I shutdown two of the three servers the problems are over. De path doesn't changes anymore and the performance is very good.

It seems that all the servers are claiming the disk which caused the problems...

The only thing is...we can't turn off the two servers forever because that's not very good for the HA. Smiley Wink

What to do now? :S

Reply
0 Kudos
mike_laspina
Champion
Champion

Disconnect one physical path from one of the other servers and bring it up.

If it thrashs then switch the physical path to the other HBA.

If that works connect the second cable up to the remaining HBA port.

If this does not work then we need look at how you have zoned the switches.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
awinkel
Contributor
Contributor

Yeah!!! I've made a big step forward!

The problem is that two esxservers were connected at one sanswitch and another esx server to another sanswitch.

When I connect all the servers to one sanswitch anything works well and the performance is very good De errors are disappeared too which is a very nice thing. Smiley Happy

But...this setup is not what I want and that's an understatement. Smiley Wink

Maybe something is wrong in the configuration of the switches or maybe the esxservers need to be connected to both sanswitches...

If anyone has an idea... Smiley Happy

Reply
0 Kudos