vcpguy
Expert
Expert

PAth change

Jump to solution

Hi, traffic from my hba are going to backend SAN from vmhba1:2:140:1. I have a Active-Active Array. I would like to change the path (basically forcing it use another HBA). When I change the path to vmhba2:1:140:1 still on the Server -> Configuration-> Device it shows that it using the old path i.e vmhba1:2:140:1.

But when I click on th properties of the Lun under the Paths it shows that vmhba2:1:140:1 is active.

I am not sure why it is not getting updated ?

Thanks

----------------------------------------------------------------------------- Please don't forget to reward Points for helpful hints; answers; suggestions. My blog: http://vmwaredevotee.com
0 Kudos
1 Solution

Accepted Solutions
Yattong
Expert
Expert

Hey,

The path has changed.

When you view the datastore from the initial Storage view, you'll only see the "Carnicol Name" (first path detected for that device).

You have to look at the properties in the window below to see the active path.



If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

~y

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points ~y

View solution in original post

0 Kudos
5 Replies
geddam
Expert
Expert

What version of ESX?

Where exactly do you see that I/O is still happening via old path....?

Thanks,,

Ramesh. Geddam,

VCP 3&4, MCTS(Hyper-V), SNIA SCP.

Please award points, if helpful

http://communities.vmware.com/people/geddam?view=documents

http://communities.vmware.com/blogs/rameshgeddam

Thanks,, Ramesh. Geddam,
0 Kudos
vcpguy
Expert
Expert

Ramesh, thanks for your reply.

I am using esx build - 163429. VC 2.5 update 5. I dont see any I/O all I need to know, is why did it not udpate the path. in the Configuration -> storage-device.

Thanks

----------------------------------------------------------------------------- Please don't forget to reward Points for helpful hints; answers; suggestions. My blog: http://vmwaredevotee.com
0 Kudos
Yattong
Expert
Expert

Hey,

The path has changed.

When you view the datastore from the initial Storage view, you'll only see the "Carnicol Name" (first path detected for that device).

You have to look at the properties in the window below to see the active path.



If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

~y

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points ~y

View solution in original post

0 Kudos
tbraechter
Contributor
Contributor

Ich bin zurzeit nicht im Hause. Ich kehre am 03.05.10 zurück. Bitte wenden Sie sich in dringenden Fällen an Thomas Dierkes (Thomas.Dierkes@havilog.com) oder Daniel Lübbe (Daniel.Luebbe@havilog.com).

I'm currently out of office. I will be back on 03.05.10. In urgent cases please contact Thomas Dierkes (Thomas.Dierkes@havilog.com) or Daniel Lübbe (Daniel.Luebbe@havilog.com).

0 Kudos
geddam
Expert
Expert

Configuration->Storage-device...I didn't understand where you are pointing to.

If you are talking about Host->Configuration->Storage-adapters...you may see the path with vmhba1...thats expected.the correct way to confirm is....

1. Login to host with root access.

2. run esxcfg-mpath -l and see which path is "on active"

Thanks,,

Ramesh. Geddam,

VCP 3&4, MCTS(Hyper-V), SNIA SCP.

Please award points, if helpful

http://communities.vmware.com/people/geddam?view=documents

http://communities.vmware.com/blogs/rameshgeddam

Thanks,, Ramesh. Geddam,