VMware Cloud Community
COS
Expert
Expert
Jump to solution

Order of VM startup - ESX Ent 2 Node Cluster

We have a 2 node ESX 3.5 cluster using a VIM server to manage. When the power died on both nodes, we noticed the VIM server did not come up. We thought it was set to be first to start on the ESX host it was on but DRS may have moved it at some point. Is there a setting we can use to make sure the VIM server is the first to fire up after a major power outage?

Thanks

Reply
0 Kudos
1 Solution

Accepted Solutions
Troy_Clavell
Immortal
Immortal
Jump to solution

here's the answer


The Virtual Machine Startup and Shutdown (automatic startup) feature is disabled for all virtual machines residing on hosts that are in (or moved into) a VMware HA cluster

.

View solution in original post

Reply
0 Kudos
8 Replies
RParker
Immortal
Immortal
Jump to solution

Configuration. VM start up / shut down

Reply
0 Kudos
COS
Expert
Expert
Jump to solution

We did that as a test. Set the VIM server as "Automatic Startup" on the ESX host it is on, then we vmotioned it to the other ESX host and it went back to "Any Order". My issue is if you make that setting on the hosting ESX server and DRS moves it due to load, then that setting does not follow the VM and defaults down to "Any Order". I want it to be the first regardless of which ESX host it was on.

Reply
0 Kudos
Troy_Clavell
Immortal
Immortal
Jump to solution

that setting should stick, it's per VM, not host. Also, you may try the restart priority in HA. Finally, if there are not enough resources in your cluster and Admission control is enabled that VM may not power on.

..

Reply
0 Kudos
Troy_Clavell
Immortal
Immortal
Jump to solution

one final thing.. if you don't have startup/shutdown options enabled on all your hosts, the vm will go into "any order". Either enable startup/shutdown on all hosts, or use the HA option.

COS
Expert
Expert
Jump to solution

Guys, for kicks, I did it twice again and it reverts back to "Any Order". I might be doing something wrong so here's what I am doing.

Fire up the Virtual Infrastructure Client.

Point it to the Virtual Infrastructure Management Server. Not directly to any of the ESX hosts in the cluster.

Click on the host the VIM server is running on, go to "Configuration" tab.

Select "Virtual Machine Startup/Shutdown", then "Properties. A new window pops up.

Put a check in the box labeled "Allow virtual machines to start and stop automatically with the system"

Select the VM in the list in the "Startup order" and click the "Move Up" button till it is in the "Automatic Startup" position.

Click OK.

That's it. Am I doing something wrong?

Reply
0 Kudos
COS
Expert
Expert
Jump to solution

I just confirmed that both hosts have that enabled. I also set it as high priority in HA. I tested it agan by vmotioning it and again it got dropped into "Any Order".

Reply
0 Kudos
Troy_Clavell
Immortal
Immortal
Jump to solution

I just confirmed your test as well. I was unaware that the startup/shutdown options would break in a HA/DRS cluster. Maybe the HA restart priority takes precedence. I'm wondering if you break HA what will happen. I don't have any environment to test that on.

Troy_Clavell
Immortal
Immortal
Jump to solution

here's the answer


The Virtual Machine Startup and Shutdown (automatic startup) feature is disabled for all virtual machines residing on hosts that are in (or moved into) a VMware HA cluster

.

Reply
0 Kudos