BDogg
Contributor
Contributor

New Load of ESX 3.0.1 - Destination Host Unreachable

It seems like I'm missing something very obvious. I installed ESX 3.0.1 on a Blade in my IBM BladeCenter. When I try to ping the default gw I get "Destination Host Unreachable"? I can ping my own IP (172.16.54.20). I've played around some with the esxcfg-vswitch things to no avail. What am I missing?

0 Kudos
8 Replies
BDogg
Contributor
Contributor

Also when I run the 'route' command it takes quite a long time for the last entry "default" to show up - compared to my other VMWare servers (2.X) the route table writes right away.

0 Kudos
BDogg
Contributor
Contributor

Could this be a link speed issue? Both of my NICs are 1000 - should the one assigned to the console be at 100?

0 Kudos
Rumple
Virtuoso
Virtuoso

I just had this problem and it was because during the install didn't pick the correct pNIC for the vswitch.

I think I used the command to list the virtual switches which showed the vmnic assigned and then I used the esxcfg-nic command to list the nics and unplugged them to identify them.

Worked great once I straightened out which nic was which.

0 Kudos
rdhickman
Contributor
Contributor

I'm testing out VI and have the same issue. I've removed all other NICs so there's only one and I've reinstalled, but it cannot ping any other address, even a router it's directly plugged into. Service Console portgroup appears to be linked to vmnic0 (which is an Intel 1000/PT server adapter, retail).

Could you potentially list the commands you used to resolve this issue?

0 Kudos
Rumple
Virtuoso
Virtuoso

esxcfg-nics -l - lists all the nics

esxcfg-vswitch -l - lists switch info

Once I realized I had the wrong vmic assigned to vSwitch0, then I used

esxcfg-vswitch vSwitch0 -U <vnic#> (wrong nic)

esxcfg-vswitch vSwitch0 -L <vnic#> (correct nic)

0 Kudos
rdhickman
Contributor
Contributor

Thanks, I seem to have only vmnic though (as predicted, since there's one card) and this doesn't appear to be the solution, for me at least.

0 Kudos
khalid_m
Contributor
Contributor

hi

i am allso facing same problem HOST unreachable as u suggest

enter command line

\[root@vm_root]# esxcfg-nics-l

...

it return result as

-blash: esxcfg: command not found

please can u specify where to put these command. i am new to vmware and linux enviroment

thank u in adavance

0 Kudos
Rumple
Virtuoso
Virtuoso

you are at the correct spot.

type esxcfg and then keep hitting the tab key. After a couple times it should list all the commands that start with esxcfg. Remember that with linux all commands are case sensitive as well so esxcfg-vswitch is not the same as esxcfg-vSwitch. Be sure to match the case from that above listing.

In your case, the actual command is esxcfg-nics and the -l is a switch (for list).

\# esxcfg-nics -l

We just rebuilt the test environment yesterday using my instructions and I forgot to change the network screenshot so we ended up screwing up the networking. I'll copy/paste the commands we used to change the NIC order.

0 Kudos