jasonjones1967
Contributor
Contributor

NFS used for Datastore (ESX 3.5)

Jump to solution

Using a NETAPP filer, i have exported the volume /vol/nfstest. given the host read/write and root access.

When I add this export onto the esx server (either gui - add file system, or esxcfg-nas commands) I can see the storage, and ESX allows me to pick the datastore for new machines/disks, but allways fails.

I have checked firewall, permissions on netapp, vmkernel has ip etc

.

Its driving me mad - presumably I have missed something of vital importance - anyone got a pointer or two?

Cheers

0 Kudos
1 Solution

Accepted Solutions
fablehouse
Contributor
Contributor

please disable root-squash on the Filer

either by setting anon=0 or root= yourhost

View solution in original post

0 Kudos
5 Replies
Texiwill
Leadership
Leadership

Hello,

If you are mounting the netapp as a Datastore you do not need to modify the SC firewall. However, you do need a vmkernel portgroup on a vSwitch that can talk to the Datastore.

login to the SC and run 'vmkping netappIP' and see if you can reach the netapp from the vmkernel.


Best regards,

Edward L. Haletky

VMware Communities User Moderator

====

Author of the book 'VMWare ESX Server in the Enterprise: Planning and Securing Virtualization Servers', Copyright 2008 Pearson Education. CIO Virtualization Blog: http://www.cio.com/blog/index/topic/168354, As well as the Virtualization Wiki at http://www.astroarch.com/wiki/index.php/Virtualization

--
Edward L. Haletky
vExpert XIII: 2009-2021,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos
Paul_Lalonde
Commander
Commander

You need to ensure that the ESX Server has full rights to the NFS export on the NetApp filer. On a normal NFS server, you need to export a share with no_root_squash to ensure that ESX can mount the volume with 'root' privileges and manipulate the filesystem. I recall having to configure something similar on the NetApp to ensure that the ESX Server has full rights to the volume.

Paul

fablehouse
Contributor
Contributor

please disable root-squash on the Filer

either by setting anon=0 or root= yourhost

View solution in original post

0 Kudos
jasonjones1967
Contributor
Contributor

several suggestions for no_root_squash (presume this is different to granting the host root access as well as read/write)

Cheers for the pointer --- will now battle through netapp pages to find out how to root squash

0 Kudos
jasonjones1967
Contributor
Contributor

cheers --- finaly worked out that no_root_squash same as anon login --- all up and running - cheers all

:smileysilly:

0 Kudos