f_gaviria
Contributor
Contributor

Migrating a guess server to an esx box

when i tried to migrate a guess server being host on one of my esx box i get the following error:

"unable to migrate from esx02......to esx02 ...A general erro occurred; the destination host is not properly configure for HA"

I remember running into this issue in the past and i just don't remember how i fixed.

can any of you hel me resolved this ASAP PLEASE

0 Kudos
14 Replies
rossb2b
Hot Shot
Hot Shot

make sure your destination host is configured and licensed for vmotion

0 Kudos
f_gaviria
Contributor
Contributor

Thanks so much for you quick response.

I'm pretty sure it it license for Vmotion. How can i checked this to be sure?

0 Kudos
Troy_Clavell
Immortal
Immortal

Thanks so much for you quick response.

I'm pretty sure it it license for Vmotion. How can i checked this to be sure?

probably the easiest way to check your licensing is to highlight the host, go to the configuration tab and then click on licensed features.

Also, under the configuration tab, select networking, make sure you have a VMKernal port and vmotion is enabled.

0 Kudos
rossb2b
Hot Shot
Hot Shot

From VC click on your esx host and go to the Configuration tab

Click on Licensed Features - check that Vmotion is licensed for both

servers

Under Configuration, Networking

Check to make sure you have a Vmkernal Port assigned to a virtual switch

and have a physical adapter attached. On the Virtual Switch click

Properties, click the Vmotion Port group, check to see if Vmotion is

Enabled.

0 Kudos
ChrisMT
Enthusiast
Enthusiast

That HA error could be the result of a few problems, one of the most common from what I've seen, being a DNS resolution problem. If the first Host's HA can't ping the 2nd Host's HA Agent, then HA will have an error, and you will be unable to VMotion between hosts.

One way to check would be to putty in to a host's CLI, and attempt to ping the other ESX Host, by name and IP. If you can do both then you "should" be able to "reconfigure for HA" the Hosts in the cluster and pray that the HA issue resolves itself.

Another trick I've seen work in 3.0.1 clusters, is set the HOSTS file on the VC server to have the ESX host information in it.

Worst case, disable HA on the cluster, wait a few minutes, and then re-enable it and see what happens.

0 Kudos
ChrisMT
Enthusiast
Enthusiast

If your still having problems, I can find and link some articles that hopefully will help you resolve the HA issue.

0 Kudos
f_gaviria
Contributor
Contributor

Thanks so much for your good input, i will try this and will let you know

0 Kudos
f_gaviria
Contributor
Contributor

Christ Thanks so much for your quick response. i have check DNS for this server and everything looks ok. i think your idea to reconfigure the HA sounds logical. How do i reconfigure the HA on this server again.

Thanks Christ

0 Kudos
ChrisMT
Enthusiast
Enthusiast

Right Click on a ESX Host in the cluster, and click "Reconfigure for VMWare HA", typically do this on the first host that was in the cluster, then any other one.

If this doesn't work, Right Click on the Cluster itself, and go to "Edit Settings", and Uncheck "HA", and then click OK. This will reconfigure the cluster's setup, and after a few minutes should be done. After it's completed (check status on bottom of VC), go back in and recheck HA, and click Ok again.

Did you ever have HA working in the past that you know of? And were you able to also VMotion if the first part is true?

0 Kudos
f_gaviria
Contributor
Contributor

Christ thanks so much i will try this approach and will let you know if it did the trick.

Thanks again Christ so much

0 Kudos
f_gaviria
Contributor
Contributor

I did the procedure described below and it resolved my issue

Thanks again so much for your good will and quick response.

Right Click on a ESX Host in the cluster, and click "Reconfigure for VMWare HA", typically do this on the first host that was in the cluster, then any other one.

If this doesn't work, Right Click on the Cluster itself, and go to "Edit Settings", and Uncheck "HA", and then click OK. This will reconfigure the cluster's setup, and after a few minutes should be done. After it's completed (check status on bottom of VC), go back in and recheck HA, and click Ok again.

Did you ever have HA working in the past that you know of? And were you able to also VMotion if the first part is true?

0 Kudos
f_gaviria
Contributor
Contributor

This did the trick Christ

Thanks so much

0 Kudos
ChrisMT
Enthusiast
Enthusiast

Your welcome, glad it worked for you 😃

0 Kudos
Troy_Clavell
Immortal
Immortal

Kudos to you !

Hey f_gaviria how bout awarding ChrisMT some answer points for all his hard work.

Also, if any other posts helped you, please consider awarding points to others as well.

0 Kudos