VMware Cloud Community
killjoy1
Enthusiast
Enthusiast

Kickstart questions and problems. 3.0.2 PXE.

I am trying to PXE boot from my PXE server which is running Ubuntu. I am able to boot via NFS and find the installation files, but I am unable to get my box to use the ESX made ks.cfg file. It seems no matter how I command it to use it that it skips right over it. The box pxe boots and finds the media and starts installation like normal with the interactive start.

What do others have for their grub file? This is mine.

title ESX Server

root (nd)

kernel /vmlinuz ks=nfs::/opt/esx/ks.cfg ksdevice=eth0

initrd /initrd.img

Can anybody tell my why its overlooking my ks.cfg file?

Thanks.

Message was edited by:

killjoy1

Reply
0 Kudos
8 Replies
esiebert7625
Immortal
Immortal

You might check out this huge kickstart thread....

Scripted installs thread (Kickstart) - http://www.vmware.com/community/thread.jspa?threadID=90424

Reply
0 Kudos
killjoy1
Enthusiast
Enthusiast

Thanks, I have read that thread extensively, but have not found my answers.

There seems to be different opinions on which commands to enter in the grub.

-kjo

Reply
0 Kudos
Texiwill
Leadership
Leadership

Hello,

Your best bet is to place your ks.cfg file on an HTTP server, for some reason using nfs to share the ks file does not always work.

boot text ks=http://machine/ks.cfg ksdevice=eth0

Setting up an HTTP server on Ubuntu should be pretty straightforward. Or you can debug the NFS session, most likely your /etc/exports is incorrect. Check /var/log/messages on your ubuntu server for errors regarding NFS.

HTTP always works for me for the ks file.

Best regards,

Edward

--
Edward L. Haletky
vExpert XIV: 2009-2023,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
Reply
0 Kudos
killjoy1
Enthusiast
Enthusiast

To add the fire it looks like there may be a bug in the vmlinuz file of the 3.0.2 version. When I PXE boot that I am getting an error:

The VMWare ESX Server 3 installation tree in that directory does not seem to match your boot media."

Has anybody updated their PXE server to use the new version?

Message was edited by:

killjoy1

Reply
0 Kudos
killjoy1
Enthusiast
Enthusiast

Well, we are a bit closer at least. The problems lies in the fact that ESX doesn't have a driver for Nvidia nics which is what our Sun X4100 M2's have (2 Intel and 2 Nvidia). When trying to PXE boot it would boot from the Nvidia boot agent s once we unplugged the Nvidia nics and controlled PXE in the bios (using the Intel agent) we got farther than before. Now I am failing with something inb the partitioning scheme, but at least we got past that particular part of it. I wish 3.0.2 worked for PXE because taht is supposed to have the new Nvidia drivers.

Just thought I would update.

Reply
0 Kudos
virtech
Expert
Expert

I have seen this error "The VMWare ESX Server 3 installation tree in that directory does not seem to match your boot media."

It was because my boot.iso I was using for my cd based builds was from a previous version. (3.0.1)

You need to update your boot files with the boot.iso from the 3.0.2 media.

Reply
0 Kudos
killjoy1
Enthusiast
Enthusiast

AFAIK, that file is not used with PXE boot. The only files that are used are inird.img and vmlinuz.

Reply
0 Kudos
Paul_Reed
Contributor
Contributor

I am using PXE with Altiris 6.5 to install ESX 3.0.2 just fine to my IBM HS20 Blades....

I am using Loadlin.exe (included on ESX3.0.2 media) to kick off the install from a FreeDOS based PXE image.

Due to the nvidia driver issue you mentioned, you may have to compile a new initrd.img for use with the PXE installation that would have that driver included.

I beleive you can do that from a running system using the mkinitrd command ...

For my installation, I have copied the entire contents of the 3.0.2 CD to the ESX302 directory on my network share (mapped with "net use" to f:). HTTP and FTP are also enabled to facilitate my deployment.

Here is the loadlin command line that i use:

"f:\Deploy\ESX302\dosutils\loadin.exe @f:\Deploy\params.par"

Here is my loadlin params.par file:

\----


f:\Deploy\ESX302\isolinux\initrd.img

nofb

ramdisk_size=9216

ksdevice=eth0

ks=http:///Deploy/esx302ks.cfg

\----


NOTE1: 'ksdevice' had to be before 'ks' for it to work correctly for some reason.

NOTE2: 'nofb' was required with the HS20 blades or the video would not appear using the remote management.

My kickstart file was copied from a manual CD installation with the following additions to the main section for ftp installation and vmware specific options:

\----


url --url ftp:// --edition=esxFull

\----


Hope this helps...

Reply
0 Kudos