renpen
Contributor
Contributor

IBM 3650M2

Anyone had any issues installing ESX 3.5 (any update) onto a IBM 3650M2 Server. After the install the server loads up until the initializing scheduler screen and then the servers freezes. We have tried with Bios ver 1.00 and ver 10.01.

We have installed ESX4 with UEFI ver 1.00 with success but updating to UEFI 1.01 we get an IRQ error once the system had loaded. -

0 Kudos
12 Replies
AndreTheGiant
Immortal
Immortal

Is your system in HCL?

http://www.vmware.com/resources/compatibility

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
renpen
Contributor
Contributor

Yes, is covered both by vmware HCL and IBM Server Proven.

0 Kudos
AndreTheGiant
Immortal
Immortal

Have you tried with some advanced kernel parameters like noapic or apci=off?

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
renpen
Contributor
Contributor

We have tried enableing and disabling every setting in the BIOS. There is no specific setting for ACPI in the M2 system.

0 Kudos
AndreTheGiant
Immortal
Immortal

During CD boot process you can press F1 and pass some parameters to Linux kernel.

You can try to pass noapic or acpi=off (or acpi=ht).

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
Scissor
Virtuoso
Virtuoso

Oh oh :). I just bought 10 IBM x3650 M2 servers and plan to attempt to install ESX 3.5u4 tomorrow.

I'm still trying to figure out this new-fangled UEFI they now use. What was wrong with the traditional BIOS? Smiley Happy Although the IBM specifications state that UEFI allows for faster booting, for me it seems to take many more minutes before the UEFI finishes initializating than I would expect.

Please let me know how things go.

0 Kudos
renpen
Contributor
Contributor

Interesting, please let me know how you go. I have IBM looking at the issue at the moment as we are a Business Partner. They have an ESX 3.5 installed system withouth any issues. I don't know what my servers have or don' thave compared to what they have.

Have you purchaed the MR10i controller or sticking with the BR10i?

0 Kudos
mjpagan
Enthusiast
Enthusiast

I had a weird issue with a IBM Bladecenter S and some blades with getting ESXi 3.5 to boot. I was using the current 3.5 U4 and eventually tried a IBM flavored ESXi version of U4. Here is the link that I used to get past my issue: IBM ESXi 3.5

It may not exactly fit your issue (I don't remember the errors I was getting) but it'd be worth a try.

Mike

Mike Pagán MCITP:EA, MCSE, VCAP5-DCA, VCAP5-DCD,VCP 5, VCP5-DT, CCNA, A+
0 Kudos
Scissor
Virtuoso
Virtuoso

I'm still trying to figure out this new-fangled UEFI they now use. What was wrong with the traditional BIOS? Smiley Happy Although the IBM specifications state that UEFI allows for faster booting, for me it seems to take many more minutes before the UEFI finishes initializating than I would expect.

Ok, so the x3650 M2 uEFI takes about 2min 10 secs to finish booting. Guess that's "normal". I think I am just used to being able to bypass the splash screen and see what's being tested.

I have the MR10i RAID controller and created a mirrored drive to install ESX to. While the ESX3.5u4 installer was able to see/install to the mirrored drive, after rebooting the system didn't seem to even try booting off the mirrored drive. The fix for me was to enable "Legacy Only" boot option in the uEFI and put it first in the Boot Order -- enter the uEFI setup ( F1 key ) -> Boot Manager -> Add Boot Option -> Legacy Only -> Confirm -> Change Boot Order -> Move "Legacy Only" to the top. Save changes and then reboot the system.

0 Kudos
renpen
Contributor
Contributor

Scissor, so did the system boot OK and all normal. If so I think my issue is the raid controller as I have the BR10i..

0 Kudos
Scissor
Virtuoso
Virtuoso

Scissor, so did the system boot OK and all normal. If so I think my issue is the raid controller as I have the BR10i..

Yes my systems booted ok. ESX complains about not having enough RAM bays populated, but that will be remedied later on this week when my RAM comes in. I haven't start running any Guests yet, but so far so good. fingers crossed

0 Kudos
Scissor
Virtuoso
Virtuoso

There is a new eEFI and IMM firmware update available for the x3650 M2. Maybe that will help you?

0 Kudos