strackan
Contributor
Contributor

How do I create a new virtual machine in an NFS datastore

I have created and successfully (I think) mounted an NFS remote drive on a Linux Server. I can view it as a datastore, access the drive, and even transfer files in the Infrastructure client.

However, when I try to create a new Virtual Machine and specify my NFS datastore, I receive a generic 'Unable to Access File' error, and server logs just show a lot of write errors.

I suspect this has something to do with user privileges, but I can't for the life of me get ESX to create a VM in this datastore.

Any help or tips would be greatly appreciated. I'm happy to provide any additional information.

Tags (2)
0 Kudos
7 Replies
prakashraj
Expert
Expert

Hi ,

Which linux distribution are you using for NFS?

Check http://www.linux.org/docs/ldp/howto/NFS-HOWTO/server.html

Prakash

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!
0 Kudos
azn2kew
Champion
Champion

Were you able to create new folder using VI Client->host->Configuration->Datastore->NFS LUN-> and browse to open it and create it? What do you see on the vmkernel logs? Seems like you have issue with write permission. Post your logs for details.

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!

Regards,

Stefan Nguyen

VMware vExpert 2009

iGeek Systems Inc.

VMware, Citrix, Microsoft Consultant

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!! Regards, Stefan Nguyen VMware vExpert 2009 iGeek Systems Inc. VMware vExpert, VCP 3 & 4, VSP, VTSP, CCA, CCEA, CCNA, MCSA, EMCSE, EMCISA
0 Kudos
JoJoGabor
Expert
Expert

Its likely to be the way the NFS export on the LInux server has been configured. is root access granted? Is it exported as read/write?

0 Kudos
azn2kew
Champion
Champion

Do you have no_root_squash in the export file? Check your permission again. What happen if you do quick test using chmod 777 on /mnt/yournfsmount if you still get the error?

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!

Regards,

Stefan Nguyen

VMware vExpert 2009

iGeek Systems Inc.

VMware, Citrix, Microsoft Consultant

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!! Regards, Stefan Nguyen VMware vExpert 2009 iGeek Systems Inc. VMware vExpert, VCP 3 & 4, VSP, VTSP, CCA, CCEA, CCNA, MCSA, EMCSE, EMCISA
0 Kudos
strackan
Contributor
Contributor

When I browse to the datastore, using the datastore browser, I can create a new folder and access it, so it appears I have write permission to the datastore, at least from within the datastore browser.

I don't seem to have any vmkernel logs. When I browse System Logs or run Get-LogType, I only see options for hostd and messages. Hostd just seems to show a bunch of generic write failures.

0 Kudos
strackan
Contributor
Contributor

I'm not sure...here is my /etc/exports file, which I used to set up the NFS share. Do I need to modify / create any additional files on the Linux share

-


#

/home *(rw)

/mnt/jbook *(rw,no_acl,wdelay,root_squash)

0 Kudos
strackan
Contributor
Contributor

Here is my exports file:

#

/home *(rw)

/mnt/jbook *(rw,no_acl,wdelay,root_squash)

Should I try changing that to:

#

/home *(rw)

/mnt/jbook *(rw,no_acl,wdelay,no_root_squash)

?

Already tried chmod 777

0 Kudos