jamcm
Contributor
Contributor

HA Help

Does anyone know why HA seems to need to be reconfigured a lot? In my DRS cluster some of the esx servers show an alarm saying HA agent is not responding.

When i check the status on the esx servers I can see some servers in showing primary agent is running and some secondary. What is primary vs secondary and what condition would cause this?

Any help is appreciated.

0 Kudos
4 Replies
weinstein5
Immortal
Immortal

I would look at your management to make sure there are no netwrok issues - in regards to the primary and secondary nnodes - primary nodes are the master nodes they maintain the catalog of all running VMs and hosts they are on - they are the nodes that initiate the cluster failover - secondary nodes just are members of the clusters -

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
rDale
Enthusiast
Enthusiast

upgrade to vcenter 2.5 U4

0 Kudos
jamcm
Contributor
Contributor

I have already upgraded to 2.5 U4.

It seems to be worse since the upgrade. Is there a way to manually uninstall the ha agent and re install?

0 Kudos
java_cat33
Virtuoso
Virtuoso

Make sure DNS is ok between the ESX hosts.

Delete the file FT_HOSTS from the host that is having issues (it contains esx host service console addresses for HA comms etc).

Restart hostd - service mgmt-vmware restart

Re-configure the host for HA