SpaceChimp
Contributor
Contributor

Enabling Jumbo Frames

G'day,

I'm trying to enable Jumbo Frames on a ESX 3.5.0 server.

I've setup Jumbo Frames on the vSwitch, now I need to do the port group. I've attempted to create a new port group and set the MTU to 9000 using the following syntax: esxcfg-vmknic -a -i -n -m 9000 "iSCSI Net B"

I'm pretty sure the syntax is correct but i receive a message stating "Error performing operation: Unable to find a PortGroup with the Name iSCSI Net B".

I thought the idea was that you had to create the port group as jumbo frames could not be set on an exising port group. This error makes it look like it's looking for an existing port group. I tried running the command on an existing port group and got the same message.

At this stage I'm stuck so any assistance would be greatly appreciated. Any ideas?

Cheers,

SpaceChimp.

Tags (4)
0 Kudos
4 Replies
TomHowarth
Leadership
Leadership

Welcome to the forums, I am moving your post to the dedicated ESX 3.5 forum

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

Tom Howarth VCP / vExpert

VMware Communities User Moderator

Blog: www.planetvm.net

Contributing author for the upcoming book "[VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment|http://my.safaribooksonline.com/9780136083214]”. Currently available on roughcuts

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
0 Kudos
athlon_crazy
Virtuoso
Virtuoso

I tested the same command on my system (3.5U3), and it work as expected. By the way, it's looking for in place ready port group instead the new one. Unlike ESX 4, you can do on both.

vcbMC-1.0.6 Beta

vcbMC-1.0.7 Lite

http://www.no-x.org
0 Kudos
ShaneWendel
Enthusiast
Enthusiast

The quintissential guide for this is here:

Look in page 2 of the comments for the step by step.

My guess? You don't have a space between "-m 9000" and your portgroup name. Wrapping in the console caused me to do this a couple of times myself. Smiley Happy

Shane Wendel, VCP

http://fatalsync.wordpress.com

----------------- Shane Wendel VCP: vSphere 4 VCP: VI3 http://fatalsync.wordpress.com
0 Kudos
Adam-ProInteg
Contributor
Contributor

Here's how I got it to work on vSphere. My virtual switch is vSwitch1 and my kernal port is VM-iSCSI

I paused all the VM's running off the iSCSI SAN (OpenFiler). I previously configured OpenFiler for Jumbo Frames and the Dell switch.

        • Delete the VMKernal port from the vSphere client "GUI"

You will need to SSH to the console and change to SU "Super User" then you can execute:

esxcfg-vswitch -m 9000 vSwitch1

esxcfg-vswitch -A "VM-iSCSI" vSwitch1

esxcfg-vmknic -a "VM-iSCSI" -i 192.168.1.49 -n 255.255.255.0 -m 9000

Run: esxcfg-vmnic -l

# esxcfg-vmknic -l

Interface Port Group/DVPort IP Family IP Address Netmask Broadcast MAC Address MTU TSO MSS Enabled Type

vmk0 VM-iSCSI IPv4 192.168.1.49 255.255.255.0 192.168.1.255 00:50:FF:77:15:FF 9000 65535 true STATIC

it's working. Smiley Happy

Adam

www.professionalintegrations.com

949-581-1099

0 Kudos