James_M-F
Contributor
Contributor

Enabling HA

Jump to solution

Good Afternoon all,

I have a quick question that I hope you will be able to help me with I have just created a cluster with DRS and HA enabled. While DRS has gone through fine, when I activated HA I have been presented with two configuration Issues:

1 - Insufficient resources to satisfy HA failover on cluster DR Cluster in DR

2 - Unable to contact a primary HA agent in cluster DR Cluster in DR.

I'm guessng the 2nd error is due to the first, how can I check/enable one of the agents to be the primary.

Your help is much needed!

regards

James

0 Kudos
1 Solution

Accepted Solutions
bjmoore
Enthusiast
Enthusiast

How many hosts are in your cluster? The first error is most likely because of the second error. I'd suggest looking in your /etc/hosts file to make sure that all servers are in there in lower case. Once that's taken care of, disable and re-enable HA on your cluster and both errors should clear up.

View solution in original post

0 Kudos
8 Replies
Prashanth_John
Enthusiast
Enthusiast

Hi

First of all you need to make sure the ESX hosts that you are trying to configure is configured in your DNS...that is you should be able to ping the DNS names of all the ESX Hosts that you intend adding into the HA cluster. The HA agent which is in the service console uses DNS to communicate with the HA hosts.

0 Kudos
Prashanth_John
Enthusiast
Enthusiast

You could also check the following log for some errors

/opt/LGATOaam512/log/*

0 Kudos
masaki
Virtuoso
Virtuoso

you must go under /opt/LGTOaam512/config or ...bin

0 Kudos
masaki
Virtuoso
Virtuoso

1 You set a too big failover value (ex: 2 with 3 hosts)

2 It can be a defualt gateway not pingable.

The primaries are listed here:

/opt/LGTOaam512/log/aam_config_util_listprimaries.log

Message was edited by:

masaki

0 Kudos
bjmoore
Enthusiast
Enthusiast

How many hosts are in your cluster? The first error is most likely because of the second error. I'd suggest looking in your /etc/hosts file to make sure that all servers are in there in lower case. Once that's taken care of, disable and re-enable HA on your cluster and both errors should clear up.

View solution in original post

0 Kudos
Prashanth_John
Enthusiast
Enthusiast

If the DNS has been configured correctly then try to stop and restart the HA agent. you could do this by running the following commands in the service console.

ps ax|grep/opt/LGTOaam512/bin

the output should be somthing like

/opt/LGTOaam512/bin ftagent -dvmware

this means that the HA agent is still running. to kill the process try

/etc/init.d/LGTOAAM551_vmware stop

hope this helps

0 Kudos
James_M-F
Contributor
Contributor

Hi Guys,

I have just checked my DNS settings, yea.... the DNS servers were entered but no rr's were present. I have just added two static hosts into DNS and will give that a stab.

I will get back in a couple of minutes.

James

0 Kudos
bjmoore
Enthusiast
Enthusiast

Hope it works out for you Smiley Happy Please reward points accordingly.

0 Kudos