danielpaul
Contributor
Contributor

ESX mounts wrong path using NFS

Hi,

we are exporting two folders by NFS to our ESX-Cluster:

/gpfs/zentral/edv/vmware @esxservers(rw,no_root_squash,async,fsid=1)

/gpfs/zentral/edv/iso @esxservers(ro,no_root_squash,async,fsid=1)

/gpfs/zentral/edv/iso @centralservers(ro,no_root_squash,async,fsid=1)

But all ESX hosts are mounting the wrong path. When I mount the share "/gpfs/zentral/edv/iso" I always get the folder " /gpfs/zentral/edv/vmware".

The only way to mount the "iso-folder" is to delete the share for "vmware-folder" from /etc/exports on fileserver.

But now the mystery: from other systems (non-esx) it works w/o problems.

Does anybody has an idea? In vmkernel-log everythink looks good. Is there a possibility to debug what esx is doing

ESX-version: 3.5.0, 98103

Thanks

0 Kudos
5 Replies
kjb007
Immortal
Immortal

How are you doing the mount? Are you mounting them from the service console as NFS, or are you trying to mount them as datastores through the GUI or via esxcfg-nas?

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
0 Kudos
danielpaul
Contributor
Contributor

we tried to mount it via esxcfg-nas and by using the vcenter-gui.

0 Kudos
kjb007
Immortal
Immortal

There isn't additional logging for that command. Errors would be written to the console, and you may get additional information in the messages log. But, if that share is only for your ESX host. Disable the share on your NFS server that you are trying to map, and then retry the config on the ESX side. See if the command fails, which it should, or if it completes successfully with the incorrect share mounted.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
0 Kudos
danielpaul
Contributor
Contributor

I disabled the share on fileserver:

\[root@esxn03 root]# esxcfg-nas -a -o nevanfsproject -s /gpfs/zentral/edv/iso ISO

Connecting to NAS volume: ISO

Unable to connect to NAS volume ISO: NFS Error: Unable to Mount filesystem: The mount request was denied by the NFS server. Check that the export exists and that the client is permitted to mount it

I enabled it again:

\[root@esxn03 root]# esxcfg-nas -a -o nevanfsproject -s /gpfs/zentral/edv/iso ISO

Connecting to NAS volume: ISO

ISO created and connected.

So far it looks good. But it is the wrong path again.

Best

0 Kudos
kjb007
Immortal
Immortal

Look under /vmfs/volumes, and see if the name you provided for the second share is set to a different ID than the first share.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
0 Kudos