Tomahawk_
Contributor
Contributor

ESX kickstart installation is seeing device sda, sdb, sdc....

I am installing ESX via DVD, and HTTP kickstart to my blade server. During the install the installer prompts me: "Partition table on device sda was unreadable…", and Partition table on device sdb was unreadable…", and "Partition table on device sdc was unreadable…" etc. for what I believe to be all of my SAN drives presented to the blade. How do get the installer to skip these drives and to only format and install ESX onto the local drive (cciss/c0d0)? Here is the excerpt from my kickstart file that I am using:

install

lang en_US.UTF-8

langsupport --default en_US.UTF-8

keyboard us

mouse genericwheelps/2 --device psaux

skipx

network --device eth0 --bootproto static --ip 10.6.175.101 --netmask 255.255.255.0 --gateway 10.6.175.254 --hostname esxsvr02.localdomain

rootpw --iscrypted $1$I2FyAXFF$SyoooKYopRRmQdgSv3kQp0

firewall --enabled

authconfig --enableshadow --enablemd5

timezone --utc America/New_York

bootloader --location=mbr

reboot --eject

vmaccepteula

clearpart --all --initlabel --drives=cciss/c0d0

part / --size 5120 --ondisk cciss/c0d0 --fstype ext3 --asprimary

part /boot --size 250 --ondisk cciss/c0d0 --fstype ext3 --asprimary

part swap --size 1600 --ondisk cciss/c0d0 --fstype swap --asprimary

part /var --size 4096 --ondisk cciss/c0d0 --fstype ext3

part /tmp --size 1024 --ondisk cciss/c0d0 --fstype ext3

part /opt --size 2048 --ondisk cciss/c0d0 --fstype ext3

part /home --size 1024 --ondisk cciss/c0d0 --fstype ext3

part vmcore --size 100 --ondisk cciss/c0d0 --fstype ext3

part VMFS --size 2048 --ondisk cciss/c0d0 --fstype ext3

%packages

grub

%post

0 Kudos
7 Replies
Chamon
Commander
Commander

Two suggestions.

One is to remove the drivers for your HBA cards from your ISO and have the ks add the drivers in the post portion of the script

Two unpresent the LUNs from the host before you run the install

Here is what ours look like for the partitioning. Notice that the file type for the VMFS is NOT ext3

  1. Langauge Support

langsupport --default en_US

  1. Keyboard

keyboard us

  1. Mouse

mouse none

  1. Reboot after install ?

reboot

  1. Firewall settings

firewall --disabled

  1. Clear Partitions

clearpart --all --initlabel --drives=cciss/c0d0

  1. Partitioning

part /boot --fstype ext3 --size 250 --ondisk cciss/c0d0

part / --fstype ext3 --size 5120 --ondisk cciss/c0d0

part swap --size 2048 --ondisk cciss/c0d0

part None --fstype vmfs3 --size 10000 --grow --ondisk cciss/c0d0

part None --fstype vmkcore --size 110 --ondisk cciss/c0d0

part /var --fstype ext3 --size 4096 --ondisk cciss/c0d0

part /tmp --fstype ext3 --size 5120 --ondisk cciss/c0d0

part /home --fstype ext3 --size 1024 --ondisk cciss/c0d0

part /opt --fstype ext3 --size 3072 --ondisk cciss/c0d0

  1. VMware Specific Commands

vmaccepteula

%packages

@base

@ everything

%post

#################

  1. Configure DNS #

#################

Wow all of the # turned into 1. when I pased it in.

Message was edited by: Chamon

0 Kudos
dinny
Expert
Expert

Hiya,

You only need to remove the drivers from the ISO - you don't need to add them back in later - this is because the drivers are loaded specifically for the install - separate drivers are loaded by ESX itself, once it is installed.

I wrote a whitepaper on it ages ago:

(It was hosted on Xtraviert's site - but it doesn't seem to be there any more - pm me with your email address and I'll send you a copy...)

But even better easier just script it all - only takes 5 mins or so to amend the ISO

http://www.jume.nl/index.php?option=com_content&task=view&id=34&Itemid=5

Dinny

0 Kudos
Texiwill
Leadership
Leadership

Hello,

Add a %pre section to REMOVE the drivers for the HBA from the installer. This is the problem. You should either disconnect the cables, depresent the LUNs, or remove the drivers. On the remove timing is most important.


Best regards, Edward L. Haletky VMware Communities User Moderator, VMware vExpert 2009, DABCC Analyst[/url]
Now Available on Rough-Cuts: 'VMware vSphere(TM) and Virtual Infrastructure Security: Securing ESX and the Virtual Environment'[/url]
Also available 'VMWare ESX Server in the Enterprise'[/url]
[url=http://www.astroarch.com/wiki/index.php/Blog_Roll]SearchVMware Pro[/url]|Blue Gears[/url]|Top Virtualization Security Links[/url]|Virtualization Security Round Table Podcast[/url]

--
Edward L. Haletky
vExpert XIII: 2009-2021,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos
timmp
Enthusiast
Enthusiast

So to add to the previous thread, your kickstart file would have something like this:

  1. VMWare License options

vmaccepteula

%vmlicense_text

%packages

@base

%pre

#!/bin/sh

  1. ==============================================================

  1. This will remove the loaded HBA modules from the kernel

remove_qla() {

for i in $(lsmod | grep qla | awk '{print $1'}); do

echo Will remove: $i >> /dev/tty1

rmmod $i

sleep 1

done

}

remove_lpfc() {

for i in $(lsmod | grep lpfc | awk '{print $1'}); do

echo Will remove: $i >> /dev/tty1

rmmod $i

sleep 1

done

}

remove_qla

sleep 2

remove_qla

remove_lpfc

%post

The above should remove the Emulex and Qlogic HBA's prior to installation.

0 Kudos
mcowger
Immortal
Immortal

Thats a neat trick - never thought of that one.

Will add that to my kickstart so I dont have to shut/noshut my fiber switch ports during install.

Thanks!






--Matt

VCP, vExpert, Unix Geek

--Matt VCDX #52 blog.cowger.us
0 Kudos
timmp
Enthusiast
Enthusiast

Yes it works well. I am still paranoid and disable the fiber switch ports anyways. Defense in depths Smiley Happy

Nothing worse than mashing an existing lun or wiping one that has running vm's on it.

0 Kudos
dan_white
Contributor
Contributor

I hate to bring up an old post but that neat trick in the %pre section that Ed and Timmp suggested don't seem to work with ESX 4.0. I can open another console when the weasel installer is running and there doesn't appear to be any "qla" or "plfc" modules loaded when I manually run lsmod. Is there any way in v4 to prevent the HBA drivers from loading during the installation? I am trying to make my kickstart as fool proof as possible. Un-zoning the LUN's would be a major pain here.

Thx,

Dan

0 Kudos