Enthusiast
Enthusiast

ESX CPU usage and Windows server

Jump to solution

Still learning the ins and out of ESX and am having a hard time understand the performance metrics when viewing them through virtual center. When I view one of my hosts running in esx, the cpu usage on the box is low 0-3%, but when I view the CPU usage in virtual center, it shows like 45% usage, the box has 2 virtual cpu's. Any docs you could point me too, or any suggestions i would appreciate.

0 Kudos
1 Solution

Accepted Solutions
Enthusiast
Enthusiast

Yes it does, I'm currently running it on my 2000 guests... otherwise they consume a lot of cpu

View solution in original post

0 Kudos
21 Replies
Champion
Champion

You don't happen to have a screen saver running on that host do you?

http://blog.laspina.ca/ vExpert 2009
0 Kudos
Enthusiast
Enthusiast

Notta, I just dont understand.

0 Kudos
Champion
Champion

Is it a single CPU or SMP and if it is SMP was it converted from a non-smp hardware install?

NB. Screen savers will consume a lot of CPU because the VM emulates a video device and a screen saver keeps it busy.

http://blog.laspina.ca/ vExpert 2009
0 Kudos
Enthusiast
Enthusiast

The machine has 2 virtual cpus. I had converted a physical machine that had 2 cpus. Should I try knocking it down to one?? Is this normal behavior?

0 Kudos
Enthusiast
Enthusiast

If the os on the vm is Win2000, there's a small app you should install. It's called Vmware Idler, search for it on the vmware site.

Enthusiast
Enthusiast

Does the tool work in conjunction with esx 3.5, seems to mention 2.x

0 Kudos
Enthusiast
Enthusiast

Yes it does, I'm currently running it on my 2000 guests... otherwise they consume a lot of cpu

View solution in original post

0 Kudos
Champion
Champion

That's not relevent for ESX 3.5, it's only for ESX 2.x

http://blog.laspina.ca/ vExpert 2009
0 Kudos
Enthusiast
Enthusiast

Well... I had this issue on my 3.02 hosts, many of the 2000 vm where eating a lot of cpu while idle... I installed the app and it solve my problem...

I've previously tried to upgrade and reinstall the VMwareTools with no results... always a lot of cpu... this small service ruled...

It may be not relevant... but it worked

0 Kudos
Enthusiast
Enthusiast

Well @ this point I am willing to give it a shot. I currently have a ticket open with VMWARE and have not heard of any other good suggestions. I will attempt this off hours and see how things react on Wednesday. Its really annoying right now since it impact whats DRS thinks it should do in some cases.

0 Kudos
Champion
Champion

I think the answer for this one on ESX 3.5 will be the monitor.idleLoopSpinUS value in the vmx file. monitor.idleLoopSpinUS = 1000

This requires down time as the VM will not use the value utiil it reboots.There are others that have had success with this setting.

http://blog.laspina.ca/ vExpert 2009
Enthusiast
Enthusiast

actually in reading the post on the tool:

Note: While the wording in this document is specific to ESX Server 2.x, VMware Tech Support has found the solution to apply to ESX Server 3.x as well--specifically 3.0.1 and 3.0.2 hosts.

0 Kudos
Enthusiast
Enthusiast

Where did you find this one?

seems a good solution, instead of installing something, correct it to the source Smiley Happy

Is it documented? if so, where?

0 Kudos
Enthusiast
Enthusiast

will give that a shot as well

0 Kudos
Champion
Champion

Found it,

http://communities.vmware.com/message/880400

http://blog.laspina.ca/ vExpert 2009
0 Kudos
Enthusiast
Enthusiast

So i added the following to the vmx file:

monitor.idleLoopSpinUS = 1000

Still did not appear to fix the problem, but the vmware idler is working perfect. Can I please confirm from somone that the positon of the monitor.idleLoopSpinUS = 1000 in the vmx file matter? Right now I just threw it in @ the bottom of the file.

0 Kudos
Champion
Champion

It's good to hear the the idler is working thanks go to . On another post there was a discussion about the value of the setting, VMware indicates a recommended range of 100 - 2000. The only other possiblity is to lower the value to 100 or possibly slightly lower. But you have the issues resolved already and unless you need to keep 2000 around for a longer term I think I would go with the Idler program.

Going further would be of benifit to the community if you have time to try it.

http://blog.laspina.ca/ vExpert 2009
0 Kudos
Enthusiast
Enthusiast

I will for sure try changing the value, I would like to use that fix instead of the vmware idler program, but for now will stick with vmware idler until I can find a value that fixes the problem. Also just wanted to verify that there isnt a problem with the position of the parameter in the esx file.

0 Kudos
Enthusiast
Enthusiast

Is a nagios agent running on this server?

Last time I had this problem, it was because Nagios client was eating all the processor.

This happened on a 2k3 server but still, uninstalling/reinstalling the agent solved the problem

0 Kudos