Expert
Expert

ESX 3.5 Windows x32 Guest - Set link speed and Full Duplex to 1000Mb/s

Jump to solution

What do I need to do to configure my VM's AMD virtual NIC to 1000Mb/s Full Duplex?

If I can't, Does the virtual Intel Nic support this? If So, How do I change the NIC to an Intel and set the Duplex to Full 1000Mb/s?

0 Kudos
1 Solution

Accepted Solutions
Expert
Expert

Read this Vmare KB Articel:

Configuring the speed and duplex of an ESX Server host network adapter

Key points:

  1. Auto Negotiate <-> Auto Negotiate

  2. 1000 MB /Full Duplex <-> 1000 MB /Full Duplex

#It is not recommended to mix hard-coded setting with Auto-negotiate.

#Duplex settings—while Cisco devices only support full-duplex, the IEEE 802.3z standard does have support for half-duplex Gigabit-Ethernet.

Because of this, duplex is negotiated between Gigabit-Ethernet devices.

Configure Cisco Port if you have Cisco

http://www.cisco.com/en/US/docs/solutions/Enterprise/Data_Center/vmware/VMwaredg.pdf

Page 55

spanning-tree portfast bpduguard default

!

interface GigabitEthernetX/X

description <<** VM Port **>>

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan <id>

switchport trunk allowed vlan xx,yy-zz

switchport mode trunk

switchport nonegotiate

no cdp enable

spanning-tree portfast trunk

!

View solution in original post

0 Kudos
9 Replies
Immortal
Immortal

If you don't have VMware Tools installed, the NIC does not support Gigabit speeds. After you install VMware Tools, the NIC will be GigE/Full Duplex.

0 Kudos
Expert
Expert

That's where I'm confused. The Link speed shows in the image1.jpg as 1Gb/s but the properties in the NIC show in image2.jpg the "Full Duplex" is set to "UTP - Full Duplex" but the setting for "External PHY" is "Auto Detect" and there is no option for 1000Mb/s Full Duplex.

So what is it set to then really?

0 Kudos
Immortal
Immortal

The Link speed shows in the image1.jpg as 1Gb/s

OK, so what's the problem? Try a speed test if you get anything over 12 Mb/s you are using Gig speeds. Full duplex is not an indicator of speed and it's therefore not speed dependent. You can get full dupex at ALL speeds, 10, 100, 1000, 10000.

Full duplex means simultaneous bi-directional communication.

0 Kudos
Expert
Expert

The backup person is complaining it's slow and pointed out the settings we're not 100Mb/s Full. So I need clarification on if it is Full Duplex 1000Mb/s. Per the settings you see in the NIC settings, is it 1000Mb/S Full Duplex?

0 Kudos
Expert
Expert

Well technically speaking the Virtual NIC can scale up to as much as the underlying Physical NIC that it is connected to.

The only reason you have various different vNICs in vmware products is to support different OSs, Well i agree certain NICs perform better with certain OSs the reason for that is the way the NIC can handle certain features as per the design.

So, there is no reason for you to worry what speed the vNIC is configured from with in the VM, make sure your Physical NICs are configured with appropriate speed settings and ensure you have enough bandwith available on the pNIC.

Let me know if you need more information on this.

-Surya

0 Kudos
Immortal
Immortal

The backup person is complaining it's slow

Well what do Backup techs know about networks or infrastructure? Let's clarify something, you are running an OS in a virtualized hardware, shared on a system with virtualized drivers, virtualized IO on a shared disk drive, run virtualized CPU with software that was designed for dedicated SCSI controllers and optimized for physical environments, that's why the recommendation is to use VCB and NOT conventional backup software, they don't work, and those methods are not supported.

It's slow because the backup software is expecting 100% time but it can't get 100% CPU/Disk time in a VM, the network is fine, it's the process that is slow.

100Mb/s Full. So I need clarification on if it is Full Duplex 1000Mb/s. Per the settings you see in the NIC settings, is it 1000Mb/S Full Duplex?

That's what AUTODETECT is for, it determines the FASTEST speed, you NEVER specify the settings, you let the NIC's autonegotiate, if the backup guy is requesting that the NICS be set to a static setting, he needs to step aside and let someone else run the backups, because that's absolutely the wrong method. NEVER use static settings for the NIC, ALWAYS Auto.

Expert
Expert

Read this Vmare KB Articel:

Configuring the speed and duplex of an ESX Server host network adapter

Key points:

  1. Auto Negotiate <-> Auto Negotiate

  2. 1000 MB /Full Duplex <-> 1000 MB /Full Duplex

#It is not recommended to mix hard-coded setting with Auto-negotiate.

#Duplex settings—while Cisco devices only support full-duplex, the IEEE 802.3z standard does have support for half-duplex Gigabit-Ethernet.

Because of this, duplex is negotiated between Gigabit-Ethernet devices.

Configure Cisco Port if you have Cisco

http://www.cisco.com/en/US/docs/solutions/Enterprise/Data_Center/vmware/VMwaredg.pdf

Page 55

spanning-tree portfast bpduguard default

!

interface GigabitEthernetX/X

description <<** VM Port **>>

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan <id>

switchport trunk allowed vlan xx,yy-zz

switchport mode trunk

switchport nonegotiate

no cdp enable

spanning-tree portfast trunk

!

View solution in original post

0 Kudos
Expert
Expert

Always look at the san or your local storage first.

This is often the slowest component . If you only get 12 MB/s from SAN , than it is not a network issue.

How many backups do run at the same time?

What performance do you have when you copy from a physical server with 1GBit to the VM and back ?

What is the write/read performance of your san or local storage?

Is it single threaded or multithreaded backup application ?

Expert
Expert

The pNIC is set to 1000Gb/s Full and the Cisco Switch is set to 1000Mb/s Full. The VM has multiple settings that confuse the heck out of me. See my attached images in the begining of the post.

I think the backup guy is running jobs simultaneously thus cascading stress on the host disk subsystem.

0 Kudos