Contributor
Contributor

ESX 3.0.2 / HP Management Agents 7.8.0 / DL585 - Missing agents / iLO ?

I have installed the HP Management Agents 7.8.0 on ESX 3.0.2 host on a Proliant DL585. I can http to the host and login to the "System Management Homepage". However, I get very little information.

Comparing this with another host using same ESX, HP Management Agents versions and hardware I notice the following differences :

System model (top right hand of screen) shows as Unknown (rather than "Proliant DL585 G2")

"Managment Processor" listed as none (rather than Integrated Lights-Out 2)

Main window pane has no information, only a "Overall System Status : no failed / degraded items" (rather than listing info under various agents NIC / Storage etc.) - I did select to install these during install.

I have rebooted host after install.

What am I missing ? I look at the services running on the two different hosts and I can't see any obvious differences between the two. I am not aware of any config I am missing. Is there some sort of setting relating to iLo or similar in the machine bios that I need to enable ?

Any help would be much appreciated.

0 Kudos
9 Replies
Commander
Commander

Did you install the specific ESX version - 'hpmgmt-7.8.0-vmware3x.tgz' ?

Cheers, Andy.

Contributor
Contributor

Thanks for your answer. Yes, I did use this file and install appeared to complete without problems. I believe I chose the default options, however, I was pressing y or n specifically rather than just , etc. so there is a small chance I made a wrong choice and I am missing something. I don't know too much about the options presented in the install script and I am reluctant to keep uninstalling and re-installing with different options without understanding the consequences.

I have a machine with HP Agents working to examine, but I can't see the difference between the two !

0 Kudos
Enthusiast
Enthusiast

Maybe there is something wrong with the snmp configuration file. You can compare the file from the working server with the file of the non-working server. The snmpd.conf can be found at /etc/snmp/snmpd.conf.

There should be a line in there which allows snmp access for localhost/127.0.0.1 similar like this rwcommunity communityString 127.0.0.1 where communityString is your SNMP-Community-String.

It should also work to copy the working file to your server and then restart the HP and snmp services. After restarting the services it may take a few seconds until the information is displayed on the Management Homepage.

It is also quite easy to uninstall the agents with installvm780.sh --uninstall

CU

Contributor
Contributor

SNMP config looks OK, but I've just solved it.

I looked at /var/spool/opt/hp/hpsmh/logs/error_log and founds permissions errors relating to file ..../webapp-data/webagent/csginkgo

If I manually add execute permissions to this file, and refresh web page I see the full info.

I am going to uninstall and re-install. I think there could have been an issue because I copied the contents of the *.tgz file from another location rather than unpacking on the host itself - I think this may have been what has caused the permissions issue ?.

Thanks for the suggestions.

0 Kudos
Expert
Expert

Seen this before. Uninstall the agents and reinstall, watch the installation very closely, just to ensure some soft warning is not slipping by, the installation script although better than Dell, and much better than IBM agent installations, it can miss things at times. Providing nothing odd is going on with the installation, watch for the following scenario...

When the sub-agents load, system home page must get an update from them, this is done via communication based on resolved name. When the system management page can not find the server it is running on by name, you get the issue your are experiencing. Double check your /etc/hosts file, double check your DNS configuration and lookup.

You may also notice that the system home page is loading slower than usual, this is usally a dead bang give away that you have some odd resolution or lookup issue. It happened in my case.

Oh, and of course, check and recheck the esxcfg-firewall settings before and after the HP agent reinstall.

0 Kudos
Enthusiast
Enthusiast

Hi

Have you tried the 7.90 agents? It can be found here

Cheers

David

0 Kudos
Expert
Expert

Same issue can exist for 7.6 through 7.9, I think the first time a saw the issue was 7.4.1 or 7.6.0, but do recall from 7.6.0 we saw this whenever DNS was not 100% right.

0 Kudos
Contributor
Contributor

Thanks for all the replies. After modifying the permissions, it started working. I re-installed as per my earlier post and noticed the permissions where different to before and it was working fine.

0 Kudos
Enthusiast
Enthusiast

Hi

Would you mind listing what changes you made to the file and how. Just for future reference.

Cheers

0 Kudos