mshen
Contributor
Contributor

Consolidate Backup with Backup Exec 11d

Hello,

VMware support hasn't been able to answer my questions, and the documentation is so general that it is useless. I've installed the Consolidate Backup Framework on my Backup Exec 11d server. Then installed the Backup Exec Integration Module. I ran the Install.bat file and configured the Config.js file. Everything should be working but it isn't.

I get the following error when I run browse-start.bat:

"C:\Program Files\VMware\VMware Consolidated Backup Framework\backupexec>browse-start.bat "VMware Backup" 172.20.10.40 PORT is not set, defaulting to 443 failed to prepare 172.20.10.40 for backup,
PrepareForBackup() returned error 16
C:\Program Files\VMware\VMware Consolidated Backup Framework\backupexec\command.
wsf(181, 😎 Microsoft JScript runtime error: 'name' is null or not an object
C:\Program Files\VMware\VMware Consolidated Backup Framework\backupexec> "

I'm trying to use file-level backups on certain machines and image-level backups on others. For file-level backups, I want to use VCB as opposed to a backup client. For image-level backups, I can mount the image, but I get several vmdk files, which one should I use?

0 Kudos
1 Reply
vlelli
Contributor
Contributor

Hi,

I had the same error using VCB for full backou of linux VMs.

Procedure stopped to work with the message;

PORT is not set, defaulting to 443

failed to prepare erp for backup, PrepareForBackup() returned error 16

C:\Program Files (x86)\VMware\VMware Consolidated Backup Framework\backupexec\command.wsf(181, 😎 Microsoft JScript runtime error: 'name' is null or not an object

The problem was in DNS

The ip address of virtual center vc.domain.com for an unknow reason was removed from domain.com zone.

On the backup proxy server name resolution for vc was ok because the ip was set in hosts file, but backup started to work again only when vc was defined in DNS.

Valter

0 Kudos