VMware Cloud Community
Brandon7a
Contributor
Contributor
Jump to solution

Backing up a VM using VMware Consolidated Backup

Is it possbile to backup a VM which resides on a fibre SAN while that VM is powered off? I'm trying to use VCB on our Virtual Center server (also our backup server).

Thanks

0 Kudos
1 Solution

Accepted Solutions
AndreTheGiant
Immortal
Immortal
Jump to solution

do I type in to replace ipaddr: for name mode?

Instead of ipaddr: type name:

And use the VM name in vCenter Server

Andre

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro

View solution in original post

0 Kudos
14 Replies
AndreTheGiant
Immortal
Immortal
Jump to solution

Yes, it is possible.

Andre

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
Brandon7a
Contributor
Contributor
Jump to solution

I'm not having any luck. Anyone have any suggestions on how to do this?

0 Kudos
AWo
Immortal
Immortal
Jump to solution

Should be possible as the .vmdk is mounted on the VCB and therefore no running guest is needed. Are you facing any problems?


AWo

VCP 3 & 4

Author @ vmwire.net

\[:o]===\[o:]

=Would you like to have this posting as a ringtone on your cell phone?=

=Send "Posting" to 911 for only $999999,99!=

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
Brandon7a
Contributor
Contributor
Jump to solution

The error I'm getting is:

Could not find virtual machine specified by the ipaddr:10.15.2.6

0 Kudos
AWo
Immortal
Immortal
Jump to solution

Describe your setup and what doesn't work.

Which backup software do you use?

Have you got the integration pack for this software?

Have you created the appropriate roles?

Which type of backup do you use (hot-add,....)?

...?


AWo

VCP 3 & 4

Author @ vmwire.net

\[:o]===\[o:]

=Would you like to have this posting as a ringtone on your cell phone?=

=Send "Posting" to 911 for only $999999,99!=

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
Brandon7a
Contributor
Contributor
Jump to solution

I'm using the vcbmounter through command line to do this. Here what I'm typing in:

C:\program files\vmware\vwmare consolidated backup framework\vcbmounter –h -t fullvm

I'm doing this on the backup server. The virtual machine hasn't been powered on in months so the DNS record has been deleted. I just added the DNS record for it manually. I don't want to power it on b/c I'm afraid it might screw up another server that replaced it. But if I have to power it on for a quick minute so DNS can see it then I will.

0 Kudos
Brandon7a
Contributor
Contributor
Jump to solution

It works when powered on so I know it's not a permission or role problem.

0 Kudos
AndreTheGiant
Immortal
Immortal
Jump to solution

Are you using ipaddr or name in VCB?

Try use name mode.

Andre

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
Brandon7a
Contributor
Contributor
Jump to solution

What do I type in to replace ipaddr: for name mode?

0 Kudos
AWo
Immortal
Immortal
Jump to solution

vcbmounter –h <backup server name> -u <administrator name> -p <administrator password> -a ipaddr:<VM IP> -r I:\mnt\<VM’s name> -t fullvm

When performing a mount operation, you must specify the VM by ipaddr, uuid, or moref. The ipaddr flag is used with the integration kit. When using the ipaddr flag, specify either the IP address or FQDN. When using the ipaddr:fqdn method, the VM must have been powered on with Vmware tools active at least once.

So try the UUID.

BTW, add the "-m" parameter to specify which backup type you want to use (in your case "san").


AWo

VCP 3 & 4

Author @ vmwire.net

\[:o]===\[o:]

=Would you like to have this posting as a ringtone on your cell phone?=

=Send "Posting" to 911 for only $999999,99!=

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
Brandon7a
Contributor
Contributor
Jump to solution

uuid: ??

0 Kudos
AWo
Immortal
Immortal
Jump to solution

You'll find in the .vmx file of the guest (hopefully, it has to be powered on in the past at least once to generate the uuid):

uuid.bios = "50 26 41 eb c8 70 0a da-fb 65 ee dc 30 9d d5 0f"


AWo

VCP 3 & 4

Author @ vmwire.net

\[:o]===\[o:]

=Would you like to have this posting as a ringtone on your cell phone?=

=Send "Posting" to 911 for only $999999,99!=

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
0 Kudos
AndreTheGiant
Immortal
Immortal
Jump to solution

do I type in to replace ipaddr: for name mode?

Instead of ipaddr: type name:

And use the VM name in vCenter Server

Andre

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
Brandon7a
Contributor
Contributor
Jump to solution

I used name: before but it didn't work. But when I changed the server name to all CAPS it did work with name:

Thanks!

0 Kudos