VMware Cloud Community
STappmeyer
Contributor
Contributor

AutoStart fails on ESX 3.5 after update to March 2008 patches

Dell 2900 2-2Ghz Quad core, 16GB ram, Local VMFS running ESX

3.5, 77234 (Patched with March 2008 releases.)

Updated development server with March 2008 patches and found

that Virtual Machine Startup and Shutdown (a.k.a. AutoStart) is no longer

functioning to start vms. Verified that it was enabled and VMs were in the

startup order or any order list. Un-configured

and reconfigured to ensure that configuration was correct.

Reviewed the hostd.log to see if I could verify autostart

was functioning. (I have attached it for

review.) I do not see it attempting to

start the VMs configured.

I have also attached the vmAutoStart.xml.

If I run “vmware-autostart start” from a SSH session, VMs

start in order specified in the configuration.

Thought the issue may be related to licensing. (License

server is on a VM on this server.) Moved

licensing to another system that would be available at startup with no change.

Anyone seen this issue or have suggestions for further

diagnostics.

Thanks,

Steve

Reply
0 Kudos
14 Replies
mike_laspina
Champion
Champion

Interesting, I just run the all the March patches now.

After it finished It left the autostart setting in the disabled mode.

I just tested before the patches to make sure it worked before I touched it.

I does work fine after re-enabling the autostart function so it not the patches.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
STappmeyer
Contributor
Contributor

Mike,

Thanks for the feedback. I think I will install ESX 3.5 fresh. If that works, I will re-patch. I will post the results.

Regards,

Steve

Reply
0 Kudos
Saju_C
Enthusiast
Enthusiast

Hi Steve

Have you made the below change after applying patch ESX350-200802410-BG . Not sure whether this is relevent to your issue.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100345...

Deployment Considerations

In addition to applying this patch, you will need to comment out a line in the file /etc/rc.d/init.d/mgmt-vmware.

Find the following line:

vmware_exec "$hostdName" "$VIMSH" -n -e 'internalsvc/shutdown'

Add a # at the beginning of the line.

Note: A complete fix for this issue will appear in an upcoming ESX Server 3.5 release. VMware recommends you wait for that fix. This patch provides an interim workaround for customers who require it.

Thanks

Saju

Reply
0 Kudos
STappmeyer
Contributor
Contributor

Saju,

Thanks for pointing this out. No, I had not commented the line out. Unfortunately, it did not solve my issue.

Thanks,

Steve

Reply
0 Kudos
christianZ
Champion
Champion

Are you using the patches from March the 10.th?

Reply
0 Kudos
mike_laspina
Champion
Champion

I noticed this in the patch notification. Maybe you missed an earlier patch. I had this autostart issue before and corrected it with the January patches. It could be related. The new 3.5.0 iso post dates the issue so I would use that one and then the March patches.

NOTE: VMware has discovered an issue that, under very specific conditions, might inhibit certain patches from being applied to ESX Server 3.5 hosts. The issue is fixed in the patch release for March 10, 2008. All the bundles released January 17 have been superseded by the bundles released for March 10, 2008 and the bundles for January 17, 2008 are no longer available.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
STappmeyer
Contributor
Contributor

Error still exists after reinstall/patch.

I reinstalled ESX 3.5 using the 2/20/2008 release ISO. I tested the auto start and it worked as

expected. I manually downloaded the 18

patches and the contents.xml and created a local repository on the ESX host and

installed all patches using esxupdate –n update. All patches installed without error. (Jan 08

patches never installed.)

Reviewing /var/log/messages; it reports starting vmware-autostart

at time 16:11:36.

/var/log/vmware/hostd.log reports a corresponding event at 16:11:47.270

for the Hostsvc. The hostd.log never

reports the VMs and no other entry for autostart. (Hostd.log and messages

attached.)

I am going to reinstall ESX 3.5 and install the patches one

at a time, testing between. (Should take

only a few hours. LOL)

Reply
0 Kudos
mike_laspina
Champion
Champion

I used Update Manager and it rebooted on it's own.

I wonder if they use a specific order in Update Manager that is not done in esxupdate -n update and is creating an issue?

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
STappmeyer
Contributor
Contributor

Unfortunately this is an isolated environment and my VC is running as a VM on this host. (Need to shut it down to enter maintenance mode.) I have the server back to base 3.5 with no patches. Autostart is functioning. I have not decided what order to install the patches. I will read through the releases before starting.

Reply
0 Kudos
STappmeyer
Contributor
Contributor

I have manually reinstalled all patches. I installed patches in the following order

testing the autostart when indicated.

1) ESX350-200802403-BG – Reboot and tested ok. (Installed first as a prerequisite for most of the remaining patches.)

2) ESX350-200802409-BG – Reboot and tested ok. (Installed as a prerequisite for many of the remaining patches.)

3) ESX350-200802301-BG, ESX350-200802303-SG, ESX350-200802304-SG, ESX350-200802305-SG, ESX350-200802306-BG – Reboot and tested ok.

4) ESX350-200802401-BG, ESX350-200802404-BG, ESX350-200802405-BG, ESX350-200802406-SG, ESX350-200802408-SG – Reboot and tested ok.

5) ESX350-200802410-BG, ESX350-200802411-BG, ESX350-200802412-BG, ESX350-200802413-BG, ESX350-200802414-BG, ESX350-200802415-SG – Reboot and tested ok.

Summary: Downloading all patches and the contents.xml and installing with command line from a local repository caused autostart to fail. Installing each patch manually did not identify the cause of this failure. In the end, patches are reported current in Update Manager and autostart is still functioning.

Reply
0 Kudos
STappmeyer
Contributor
Contributor

Unfortunately I spoke to soon. Autostart is not functioning with subsequent reboots of the ESX server. Back to square one. I guess I will repeat my install and test with multiple reboots before continuing.

Reply
0 Kudos
STappmeyer
Contributor
Contributor

I have installed VirtualCenter on a separate machine and used it to apply the updates to a fresh install. I have confirmed that AutoStart is enabled and it still does not function after the patch installation. Since this is a test environment, I am going to leave it broken for now.

Reply
0 Kudos
Raudi
Expert
Expert

Hello,

i have the same issue:

Installed last week from a Build 64607 and installed the patches with the Update Manager just before the Update 1 was released...

Has someone found a solution?

The Update 1 i haven't installed yet...

Best regards

Stefan

Reply
0 Kudos
STappmeyer
Contributor
Contributor

I updated this past weekend and have just started testing. The autostart of the guests is working now. I also had updated the firmware on the Dell PE2900. In other words. Lots of changes. Hard to say what corrected the issue. If you update, please post your results here.

Reply
0 Kudos