rickdi
Contributor
Contributor

Addign a LUN to be used by two hosts

Jump to solution

I have 3 host managed by a VC. Version 3.5 updated 1. I have a iSCSI SAN with 3 LUN. I have two on maniple hosts and one is unused. I am trying to add the unused one to two of the host but every time I add it to one and then to the other it seems like they stomp on each other. I cannot remember what I did to add the ones that are shared right now.

Any help woudl be much appreciated!! Thanks!!

0 Kudos
1 Solution

Accepted Solutions
kukacz
Enthusiast
Enthusiast

Are you sure you are not formatting the same LUN again on the second host? You should only do adapter rescan first, then switch to the "Storage" tab and only do "Refresh" there. The existing datastore should appear there automatically. If it doesn't, and you're sure the mapping is correct, try to restart the iSCSI stack or reboot the ESX host.

--

Lukas Kubin

View solution in original post

0 Kudos
5 Replies
christianZ
Champion
Champion

Basically you should present this lun with the same lun id for all the hosts (when possible, e.g. by EQL you can't do it - it will be done automatically).

Then on one esx host you create a vmfs volumes and that volumes should be showed on the other hosts after you rescan the storage adapter.

What storage have your there?

rickdi
Contributor
Contributor

I tried and it does the same LUN ID but when I go to add it to the second host it formats it again. Should I be adding the storage when I manage a single host or as I am doing it under the Virtual Center Server.

0 Kudos
kukacz
Enthusiast
Enthusiast

Are you sure you are not formatting the same LUN again on the second host? You should only do adapter rescan first, then switch to the "Storage" tab and only do "Refresh" there. The existing datastore should appear there automatically. If it doesn't, and you're sure the mapping is correct, try to restart the iSCSI stack or reboot the ESX host.

--

Lukas Kubin

View solution in original post

0 Kudos
rickdi
Contributor
Contributor

You are correct I just was not refreshing it.

0 Kudos
rickdi
Contributor
Contributor

Thanks!!

0 Kudos