RobinLindstrom
Contributor
Contributor

Access denied as root

Jump to solution

Hi,

I to edit the DNS settings.

DNS ip 192.168.100.29 and 100.35.

Checked alot and found this:

"modify_resolvconf"

"vimsh -n -e "/hostsvc/net/dns_set --dns- 192.168.100.29,192.168.100.35 --dns-searchdomain=mydomain.com"" (i dont need the mydomain part do I?

"cat > /etc/resolv.conf << EOF1"

I either get access/permission denied or command not found.

I have a deadline that is tight so Im praying some friendly soul can help me out Smiley Happy

one more thing, this is the first time i use linux so explane like i am a child Smiley Wink

Cheers mates,

Robin

0 Kudos
1 Solution

Accepted Solutions
weinstein5
Immortal
Immortal

You can also change the DNS settings through the VI client - go to the configuration Tab for the ESX host you want to change look for DNS and Routing under software on the left hand side and after highlighting DNS aand Routing clieck on properties on the upper right hand side and you should be able to change your DNS settings - it will require a reboot as I recall for the changes to take effect -

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

View solution in original post

0 Kudos
3 Replies
vmroyale
Immortal
Immortal

Robin,

I've seen the command not found messages as root when the "su" command was used instead of "su -"

Good Luck!

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
weinstein5
Immortal
Immortal

You can also change the DNS settings through the VI client - go to the configuration Tab for the ESX host you want to change look for DNS and Routing under software on the left hand side and after highlighting DNS aand Routing clieck on properties on the upper right hand side and you should be able to change your DNS settings - it will require a reboot as I recall for the changes to take effect -

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
0 Kudos
Natsidan
Enthusiast
Enthusiast

you need to alow access for the root user to ssh. edit the sshd.conf the section

vi /etc/ssh/sshd_config" section where it says PermitRootLogin needs to be yes

save file then do "service sshd restart"

root login will now be allowed

0 Kudos