Adrian_Rodrigue
Contributor
Contributor

iscsi software init does not see storage after ESX upgrade 3.0.2 to 3.5

I have upgraded 2 out of my 5 ESX servers to 3.5 from 3.0.2. I had iscsi setup on all 5 servers before the upgrade to run development machines. Once VMs are developed and running, I move them to our Clariion for production. I also have the local disks (DAS) setup on each box to store templates. After the 3.5 upgrade, the servers no longer see the iscsi storage. I am running openfiler 2.2 64-bit on a HP Proliant DL360 g5. I have those 3 LUNs set to 200, 201 & 202. It's still working fine on the boxes I have not upgraded. I even went to another ESX server that is not in the cluster that I had previously built new on 3.5 and it too cannot see the iscsi. Is it a problem with 3.5 or maybe 3.5 is not compatible with OpenFiler? Did I read somewhere that I can't do all three anymore - DAS / Clariion / SW iSCSI due to driver issues?

Help?!?

0 Kudos
3 Replies
bhadzik
Enthusiast
Enthusiast

Is software iscsi client allowed in the security profile on the configuration page of the esx server?

Can you do a vmkping to the iscsi target from the service console?

Adrian_Rodrigue
Contributor
Contributor

It was in fact that the firewall was blocking the port. So even though I could ping the iSCSI target the 3260 port could not connect to it. So I checked the box and it started working. I'd like to say though that I still can't find anything in the documentation referring to that.

Thanks

-Adrian

0 Kudos
mlangguth
Contributor
Contributor

This has been noted on several other threads.

If you are using the software ISCSI initiator to connect you storage under 3.0.x you will need to enable the "Software ISCSI Client" post upgrade.

Log into VCMS select the host in question. Select the configuration tab, then Security Profile on the left hand side. Select properties for the firewall. Check software iscsi client under ungrouped then click okay. You may need to rescan your adaptor to see the LUN.

Alternatively you could use the command line to enable the port, 3260 tcp.

0 Kudos