Deeshey
Contributor
Contributor

how to load modules ?

Jump to solution

Hi, after of the 3.0.1 upgrade...the Qlogic driver dont load at boot. I have to load manually with vmkload_module command. How load the module at boot?

Thanks.

0 Kudos
1 Solution

Accepted Solutions
Paul_Lalonde
Commander
Commander

Can you post your /etc/vmware/esx.conf file?

We can certainly load that VMkernel module manually in one of the startup scripts, but I'd rather find out why it isn't getting made persistent in the bootup configuration.

Paul

View solution in original post

0 Kudos
11 Replies
masaki
Virtuoso
Virtuoso

use esxcfg-module -l to see which modules are loaded.

then use esxcfg-module -e to enable a specific module

0 Kudos
Deeshey
Contributor
Contributor

the module is loaded, but if i reboot the server...the module dont load...and the vi client dont see the HBA's...then..load the module manually...click on "rescan" button in vi client...and all work fine.

thanks

0 Kudos
wobbly1
Expert
Expert

once you have loaded the module run the esxcfg-module -l command which will show you a list

you should see the qlogic module loaded but probably showing false against enabled (i.e. enabled at boot)

now run the esxcfg-module -e to enable it at boot

0 Kudos
Deeshey
Contributor
Contributor

the module is ENABLED and LOADED....but dont load at boot...i have to do manually.

Other solution?

thanks

0 Kudos
wobbly1
Expert
Expert

ok, not sure if you can do this in your environment but use esxcfg-module -d to disable and then reenable again using -e rather than the vmkmodule command and see if this corrects it

0 Kudos
Paul_Lalonde
Commander
Commander

Try:

esxcfg-boot -p -b

Then reboot the system and see if the module loads on bootup.

Paul

0 Kudos
Deeshey
Contributor
Contributor

I tried esxcfg-boot -p -b but the module dont load at boot.

Appear as "false" in the "Loaded" column. I have to load manually with vmkload_mod qla2300_707

Any other solutions? in the init.d can put something?... because if i reboot the ESX the qla modules dissappear

thanks

0 Kudos
Paul_Lalonde
Commander
Commander

Can you post your /etc/vmware/esx.conf file?

We can certainly load that VMkernel module manually in one of the startup scripts, but I'd rather find out why it isn't getting made persistent in the bootup configuration.

Paul

View solution in original post

0 Kudos
Deeshey
Contributor
Contributor

how i can load the module manually in the init scripts?

0 Kudos
Deeshey
Contributor
Contributor

i deleted the line "options" in the esx.conf and the module loaded fine Smiley Happy

The bad line was "options=qla2x_lun_queue_depth=64"

Thanks

dd

0 Kudos
masaki
Virtuoso
Virtuoso

Well done.

0 Kudos