vmwarechap
Contributor
Contributor

day-light saving update time in VM

Jump to solution

Guys,

Due to day-light saving, my VM in my test environment are running beind 1 hour. Not sure, why they did not change their time. Yes "Automatically adjust clock for daylingh saving changes" is selected in the Date and Time properties.

My ESX server 3.5 is showing a proper time. I have Vmware tools installed on all the VM. Now, I have selected time syncronization option in the Vmware Tools.

But, still I don't see any updates taking place in my VM's. Is there someother setting that needs to be done here ?

Thanks

0 Kudos
1 Solution

Accepted Solutions
BryanMcC
Expert
Expert

Make sure you download patches for your OSes here...

These need to be on all machines including the DC, if you have one. Then make sure your PDC Emulator is set to use NTP with a valid time server address.. Look under HKLM\System\Services\w32time\Parameters.

After this is verfied and the patches are applied run w32tm /resync /rediscover

Patch all members of the domain and run the same.

You may want to run net stop w32time on all machines and verify that the time is being discovered correctly from the entries in the System log.

Help me help you by scoring points.

Help me help you by scoring points.

View solution in original post

0 Kudos
5 Replies
bfent
Enthusiast
Enthusiast

Have you stopped and disabled the Windows Time service on the VM?

0 Kudos
vmwarechap
Contributor
Contributor

Yep, it was enabled. I have disabled it. now what next ?

Thanks

0 Kudos
bfent
Enthusiast
Enthusiast

Once the Windows Time service is disabled and stopped and the VMware Tools Time syncronization is enabled, the time should correct itself. If the VM's time is ahead of the host's time, you will need to roll it back so it can then auto correct.

0 Kudos
BryanMcC
Expert
Expert

Make sure you download patches for your OSes here...

These need to be on all machines including the DC, if you have one. Then make sure your PDC Emulator is set to use NTP with a valid time server address.. Look under HKLM\System\Services\w32time\Parameters.

After this is verfied and the patches are applied run w32tm /resync /rediscover

Patch all members of the domain and run the same.

You may want to run net stop w32time on all machines and verify that the time is being discovered correctly from the entries in the System log.

Help me help you by scoring points.

Help me help you by scoring points.

View solution in original post

0 Kudos
vmwarechap
Contributor
Contributor

It is kind of weired, when i install the patch, it works. When, I scan my computer from the MS site to install all the patches, it won't show this particular patch.

Any ways, thanks a lot for your help.

0 Kudos