Russell0311
Contributor
Contributor

WLB and VMware

Hi

Has anyone got any experience of virtualising Windows Load Balancing service?

I am trying to virtualise one on the nodes of a two node WLB cluster. The cluster is load balancing Outlook Web Access.

I need to vitualise a server that is running one node of the cluster but I will leaving the other node as a physical server.

I am using VMware server v1.0.4 and have used vmware converter to take an image of my WLB node but when I try to start it up the WLB it doesn't seem to want to start. I think this is probably related to the nic config. BTW I am only doing this until I can virtualise my whole environment next year with VI3.

Has anyone tried a migration of WLB?

Any experience/comments would be great.

thanks

Russell.

0 Kudos
5 Replies
TomHowarth
Leadership
Leadership

How are you doing your WLB via Mulitcast or Unicast?

Kind Regards

Tom,

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
0 Kudos
Russell0311
Contributor
Contributor

multicast

0 Kudos
TomHowarth
Leadership
Leadership

Have a read of the following posts and blogs

www.vmware.com/community/message.jspa?messageID=29939

blogs.vislab.usyd.edu.au/index.php/VNCProxy/2007/05/23/multicast_aamp_vmware

blog.baeke.info/blog/_archives/2006/2/21/1775587.html

This one is specific to Vmware Server

communities.vmware.com/thread/37402

If you found this or any other post helpful please consider the use of the Helpfull/Correct buttons to award points

Kind Regards

Tom,

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
0 Kudos
Russell0311
Contributor
Contributor

HI Tom,

Unless I am missing the point (which is quite possible) most of the documentation talks of creating a new NLB cluster, I have a cluster that I wish to migrate from physical to virtual.

So far I have used I have used the vmware p2v converter to take an image of the server I want to move and I have tried to start this up on another box but the config of NLB all looks wrong, when I look at the network card settings it is like NLB is disabled. I think this is because the NLB settings that have been migrated are assigned to the old nic and now I have an AMD virtual nic. Any pointers on how I should configure the VM so that my old nic settings come across ok? When I tried to enable NLB on the AMD virtual nic I got a message to say something along the lines of "You already have NLB installed on the hidden nic XXX, do you wish to continue? I will try it again and get the full error if this helps

thanks

Russell.

0 Kudos
FERC_ESX1
Enthusiast
Enthusiast

Go into Device Manager and remove missing hardware "View...Show Hidden Devices" Then try to configure WLBS on the new secondary NICs.