ted_byrne
Contributor
Contributor

Upgrade to VC2.0.2 Successful, but can't connect with VI client

Jump to solution

I upgraded our VC 1.4 server to version 2.02, which completed successfully after changing the http and https ports to avoid conflict with some other software installed on the server. After the VC install/upgrade process completed, I installed the VI client on the server.

Once the installs were completed, I started the VI client that had been installed on the VC server and attempted to log in. However, that fails with an "Error Connecting" popup:

"Cannot connect to host vcserver[/i]: No connection could be made because the target machine actively refused it."

My first thought was that some problem had occured causing the VC service to fail, preventing the client from connecting. However, when I checked, the VC Server service is started and there are no errors logged in the Windows Event Logs.

Any thoughts about what might be going on to prevent the client from connecting to the server?

Thanks,

Ted

0 Kudos
1 Solution

Accepted Solutions
kumarkv
Enthusiast
Enthusiast

Hi

\- I guess you have tried to set the port to 902 from the Runtimesettings menu of the VC server right?

\- Set the port to 905 , do a netsta -an and see which apps is communicating through 902

\- Have you tried installing Virtual center on another server and tried to connect it? If you want to connect to the existing Db there are steps to do the same.

let me know and ican send it to you.

Cheers Kumar KV If you find this helpful don't forget to award points

View solution in original post

0 Kudos
18 Replies
esiebert7625
Immortal
Immortal

Are you using the DNS name of the VC server to connect to it? Also try the IP address. Are you using the 2.0.2 version of the VI Client? Where he http and https ports the only ones you changed? Is VC configured for port 902? Try entering for the server name to :902 at the login screen. Check the VC server logs just to be sure the server is up and there are no errors (C:\Windows\Temp\VPX directory on the Virtual Center server)

0 Kudos
ted_byrne
Contributor
Contributor

Results of connection attempts are the same whether using IP address, hostname or localhost, with or without the port specified.

The only ports changed during the install were http and https; I can connect to VC using Web Access with http or SSL.

I did not change the configuration to use something other than port 902; is there a way to check what VC is using (or attempting to use)?

The VC server logs showed one error in a couple of different log files:

\[2007-08-12 09:52:41.102 'App' 2720 error] ODBC error: (08001) - \[Microsoft]\[ODBC SQL Server Driver]\[TCP/IP Sockets]SQL Server does not exist or access denied.

\[2007-08-12 09:52:41.102 'App' 2720 error] No pool found with id 1

\[2007-08-12 09:52:41.102 'App' 2720 error] Failed to intialize VMware VirtualCenter. Shutting down...

However, the service was still running. After seeing that error, I verified that the DSN was correct, and successfully tested the connection to the SQL server where the VirtualCenter database is running from. After that I stopped and restarted the VC Server service. Once the service was restarted, I checked the log files that had been updated; the ODBC error had not been repeated. At that point, I tried to reconnect using the VI client, but the connection still fails.

Ted

0 Kudos
esiebert7625
Immortal
Immortal

Is your VC server in a AD domain? Are you using a local or domain login?

0 Kudos
ted_byrne
Contributor
Contributor

The VC server is in an AD domain. We are using domain logins to connect.

Ted

0 Kudos
esiebert7625
Immortal
Immortal

That error is more an indication of a communication rather then a login problem. If the login is invalid you will get an error to that effect. For example if I try to connecting to a server that is not a VC server I will get that same error. Do you have any firewall software on that VC server that may be blocking ports? Any anti-virus software that might be doing the same?

0 Kudos
ted_byrne
Contributor
Contributor

That error is more an indication of a communication

rather then a login problem.

Understood - I have experienced the same issues you mention.

Do you have any

firewall software on that VC server that may be

blocking ports? Any anti-virus software that might be

doing the same?

There are no firewalls installed, aside from Windows Firewall, which is inactive. There are no antivirus products installed on this particular machine.

What is puzzling is that it was a functioning VC server prior to the upgrade; since then we have not been able to connect. I'm half-tempted to uninstall VC entirely and do a fresh install from scratch, pointing it at the existing DB which has already been upgraded.

Ted

0 Kudos
esiebert7625
Immortal
Immortal

I find the Sysinternals utilities very useful for troubleshooting network and other problems. You might try using TcpView on the VC Server and the VI Client PC to see what is happening. Also Microsoft Network Monitor is handy for finding out more.

ted_byrne
Contributor
Contributor

Thanks, I will look into those. Hopefully that will shine some light on the issue.

Ted

0 Kudos
esiebert7625
Immortal
Immortal

They have solved many a problem for me, they should be in every admins toolbox, I have the whole collection on my flash drive.

0 Kudos
kumarkv
Enthusiast
Enthusiast

1. Execute svrnetcn in the command prompt and check if TCP/Ip has been enabled and if the SQL server is running on 1433 port number

2. Doa telnet to a Virtual center server on Port 1433 . Does this work?

3. The SQL Server should run on Service Pack 4

4. The Virtual center DB user ID shld be assigned db_owner privilege

5. Check the authentication type of the SQL database

6. Do a netstat - an in the command promt ( on the VC Server) and see if the port number 1433 , 902 and in listening or established state

Let me know if this works for you. If this resolves request you to award points for the same

Cheers Kumar KV If you find this helpful don't forget to award points
0 Kudos
bjmoore
Enthusiast
Enthusiast

You might try a netstat -anb just to make sure that your VC service is running on the ports you think it is.

ted_byrne
Contributor
Contributor

OK, according to netstat, it appears that vpxd.exe is listening on port 905:

TCP 0.0.0.0:905 0.0.0.0:0 LISTENING 1472

\[vpxd.exe]

However, the connection attempt is still "actively refused" if I try to connect to localost:905.

Is that the correct syntax to specify a different port for the VI client to connect to?

I found a document from VMWorld 2006 that discusses VC2 Diagnostics, and based on that, was able to start VC in the foreground, forcing it to use port 902. At that point, I am able to connect to VC with the VI client as I would normally be able to.

I have yet to figure out why the service starts up listening on port 905 - the registry entries under VirtualCenter seem to indicate that it would be using port 902. I found no mention of port 905 there. The startup parameters field for the service is blank, so it's not getting set there.

0 Kudos
esiebert7625
Immortal
Immortal

It should be 902, you can run the install again and select repair and look at the port setup screens and make sure it is 902. Just don't overwrite your database. Alternately try connecting using the VIC as server name :905 and see if it works. I don't think this is stored in the registry, probably in a config file.

0 Kudos
ted_byrne
Contributor
Contributor

I tried connecting with

:905; it did not work. Once I started VC forcing it to use port 902, I was able to connect using either

:902 or just the server name.

It's late - I'll look at this again tomorrow...

0 Kudos
kumarkv
Enthusiast
Enthusiast

The issue that you are facing is due to the port. When you run the install a screen will come up for port numbers. Leave it to the defaults.

Apart from this is your SQL DB now getting connected? ensure the password in the VC Server is also updated.

Is your problem fixed? If my advise fixed ur problem or it helped can you award me points?

Regards

Kumar

Cheers Kumar KV If you find this helpful don't forget to award points
0 Kudos
ted_byrne
Contributor
Contributor

The port is indeed the problem, but it seems to be resistant to a solution.

I tried repairing the install (twice), leaving all ports set to default - vpxd comes up on port 905.

I tried uninstalling and reinstalling, again leaving all ports set to default - vpxd comes up listening on port 905.

0 Kudos
kumarkv
Enthusiast
Enthusiast

Hi

\- I guess you have tried to set the port to 902 from the Runtimesettings menu of the VC server right?

\- Set the port to 905 , do a netsta -an and see which apps is communicating through 902

\- Have you tried installing Virtual center on another server and tried to connect it? If you want to connect to the existing Db there are steps to do the same.

let me know and ican send it to you.

Cheers Kumar KV If you find this helpful don't forget to award points

View solution in original post

0 Kudos
tbyrne
Contributor
Contributor

I had not tried to set the port through the Runtime Settings menu; just getting connected to the VC server was a major research project. However, once I was able to connect by running vpxd as a foreround process, going in and changing the setting there fixed the problem

Thanks for the assistance and pointing that out.

Ted

0 Kudos