Maelito77
Contributor
Contributor

Unable to scp -r from one host local datastore to another host local datastore

Jump to solution

Using Putty to connect to the host server

Running command to copy VM from one datastore to another datastore (both DS hosted locally on 2 different servers)

Error: Protocol major versions differ: 2 vs. 1

- I have tried confirmed that the only protocol on both host servers are set to Protocol 1 and as I am using Putty I've the protocol to 1 also but the same error occurs.

ii

Maelito
0 Kudos
1 Solution

Accepted Solutions
dgun07
Contributor
Contributor

1 - Check SSH configuration on both sides and compare... (/etc/ssh/sshd_config)

The remote server will only accept v2 connections and you are trying to do

a v1 connection. So either enable v1 support on the remote side. Or use

v2 and id_rsa/id_dsa keys.

2 - Check ESX versions & patch level that you have in use on both side (ESX 3.xx build xxx)

3 - Also you can check ssh protocol version running rpm -qa | grep openssh.

Good Luck !

GM

View solution in original post

0 Kudos
5 Replies
SuryaVMware
Expert
Expert

Can you give us the exact syntax you are using? may be you can mask the ip-addresses if you dont want them here.

-Surya

Maelito77
Contributor
Contributor

Hi Surya

This is the command that I am running from Putty connected to the Sorce host server:

scp -r /vmfs/volumes/47ff68f0-72a6ac30-3b38-001b78bebccc/DRSG/ root@192.168.1.1:/vmfs/volumes/4797e2e7-932fcb85-2008-001e0bc76422/

Thanks

ii

Maelito
0 Kudos
dgun07
Contributor
Contributor

1 - Check SSH configuration on both sides and compare... (/etc/ssh/sshd_config)

The remote server will only accept v2 connections and you are trying to do

a v1 connection. So either enable v1 support on the remote side. Or use

v2 and id_rsa/id_dsa keys.

2 - Check ESX versions & patch level that you have in use on both side (ESX 3.xx build xxx)

3 - Also you can check ssh protocol version running rpm -qa | grep openssh.

Good Luck !

GM

View solution in original post

0 Kudos
kjb007
Immortal
Immortal

If you're sure the remote site uses v1, then you can use *scp -1 -r

/vmfs/volumes/47ff68f0-72a6ac30-3b38-001b78bebccc/DRSG/

root@192.168.1.1:/vmfs/volumes/4797e2e7-932fcb85-2008-001e0bc76422/*

-KjB

VMware vExpert

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Texiwill
Leadership
Leadership

Hello,

Protocol version 1 is insecure so it is best to use v2. If your target is an ESX server then that is the default. So if this is happening then PuTTY is setup to send protocol version 1. Change the setting to v2 and you will be fine.


Best regards,
Edward L. Haletky
VMware Communities User Moderator, VMware vExpert 2009, DABCC Analyst
====
Now Available on Rough-Cuts: 'VMware vSphere(TM) and Virtual Infrastructure Security: Securing ESX and the Virtual Environment'
Also available 'VMWare ESX Server in the Enterprise'
SearchVMware Pro|Blue Gears|Top Virtualization Security Links|Virtualization Security Round Table Podcast

--
Edward L. Haletky
vExpert XII: 2009-2020,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill