VMware Cloud Community
SL55AMG
Contributor
Contributor

Server refusedServer refused to allocate pty -

"This is what I get when I try to putty into the server"

Server refusedServer refused to allocate pty

-bash: /root/.bash_profile: Input/output error

Reply
0 Kudos
6 Replies
RDPetruska
Leadership
Leadership

OK, I'm confused. Why are you trying to putty into the VMware Communities forum website?

Reply
0 Kudos
Peter_vm
Immortal
Immortal

He is not "putty"-ing to VMware Communities forum website, he just reports a problem of connecting using putty to a Server.

Obviously this thread belongs somewhere else...

Reply
0 Kudos
RDPetruska
Leadership
Leadership

Peter - yep, I pretty much realized that. It was my attempt to get the poster to actually provide a few more details, like what VMware product he/she is using, so that one of us could move the thread to a more appropriate forum. Smiley Wink

Reply
0 Kudos
admin
Immortal
Immortal

Oops, I didn't see RDPetruska's post, so I moved this to the VI3: Installation and Upgrade community, since most of the original poster's questions have been about VI3. Rob, if you get a response and that's not the right place, please move it. Thanks.

Robert Dell'Immagine, Director of VMware Communities

Reply
0 Kudos
OVFTOOL
Contributor
Contributor

hi all,

    I encounter  the same problem while connecting to ESXi 3.5 Server in SSH. At first , the Server runs normally, which can be connected in SSH by muti computers at the same time. One day of this week, we found, the Server accepts only one connection at the same time. when we try to connect the second one, it raise "Server refused to allocate pty" "server refused to start a shell/command" and fail to login。

And we can find the follow informatin from "/var/log/messages"

May 18 19:58:04 dropbear[9263001]: failed to open any /dev/pty?? devices
May 18 19:58:04 dropbear[9263001]: no pty was allocated, couldn't execute
May 18 19:58:04 dropbear[9263001]: exit after auth (root): Exited normally

then we try "ps | grep dropbear", we can see dropbear is still runing

9804566 9804566 dropbearmulti        dropbear

Any idea about what causes this?

Reply
0 Kudos
OVFTOOL
Contributor
Contributor

anybody helps???

Reply
0 Kudos