VMware Cloud Community
Geezertronic
Contributor
Contributor

Recover a datastore removed via VI Client

Hi

We are running ESX 3.5 and VI Client 2.5. Someone has accidently removed a datastore from our configuration and when I try to re-add the datastore it keeps threatening to format it. Please can anyone advise of a process whereby I can re-add the datastore to the configuration without formatting it and loosing the data on it. The datastore is SAN attached and the LUN is attached and is visible to the storage adapter, it's just that the datastore has been removed from the Storage view.

Thanks in advance

Reply
0 Kudos
6 Replies
Cameron2007
Hot Shot
Hot Shot

in advanced settings there is an entry for LVM. Change both settings to 0 and then try re-adding.

Reply
0 Kudos
Geezertronic
Contributor
Contributor

Thanks for your reply. Please can you tell me where the Advanced settings you are referrig to is? When I try to add the datastore back in, I am:

  • Clicking on "Add Storage"

  • Storage Type = Disk/LUN

  • Device Location = the LUN number

  • Current Disk Layout = standard stuff, nowhere to amend

  • Properties = the name of the datastore

  • Formatting screen = untouched

I have not gone past the formatting screen, but I do not see an Advanced Settings option? Please can you direct me? Thanks

Reply
0 Kudos
Cameron2007
Hot Shot
Hot Shot

its on the advanced settings for the host. so go to the host, then configuration, then advanced settings and the LVM settings are in there. Not sure if this will work but its worth a try

Reply
0 Kudos
Geezertronic
Contributor
Contributor

Do you have any documentation that supports this as I am concerned that the adding process will still format the LUN and therefore I will loose all of the data on that LUN. I would like to be sure before I proceed that the data will remain intact.

Thanks

Reply
0 Kudos
Cameron2007
Hot Shot
Hot Shot

have a read at this link it supports that

http://communities.vmware.com/message/884732#884732

Reply
0 Kudos
Geezertronic
Contributor
Contributor

Unfortuately, the datastore was reformatted during the adding so I ended up having to restore from backup...

Thanks anyway!

Reply
0 Kudos