Pmico
Contributor
Contributor

Migration Failed -Virtual Machine not enough disk space on destination

I'm upgrading my servers from 2.5 to 3.02 version.

I've tried to migrate one Virtual Machine that resides on an OLD vmware server(2.5) to the new upgraded server currently in 3.02 version.

To avoid service interruption of the Virtual computer I've tried to move to a new datastore VMFS3.

But the new datastore doesn't have enough space, and the migration failed and now I can't proceed because the only option that I have on my "Virtual Interface Client" is the "Complete Migration" option.

If I click "Complete Migration" then It shows me the error that there is no enough space on destination. But I can't go ahead or back.

Another problem is that I can't unregister it from the new server, or remove or anything else to leave these virtual machine associated to their previous server.

How can I unlock it? or how can I unregister this Virtual machine from the new server to revert the situation?

Best Regards

0 Kudos
1 Reply
Texiwill
Leadership
Leadership

Hello,

On your ESX v2.5 machine does the VMDK still exist on the non-vmfs3? If not, then you will have to restore from backup.

If it is, then I would shutdown the ESX v3 system. Then reregister the VM on the v2 machine. Remember v2 can not see the vmfs3.

Otherwise all you can do is restore from backup.

Best regards,

Edward

--
Edward L. Haletky
vExpert XIII: 2009-2021,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos