J_Wright
Enthusiast
Enthusiast

HP Insight Manager Agent on ESX 3.5

Jump to solution

I have installed the hp agent (7.9.1) and I can get to the homepage on the host, but for some reason I cannot get my Insight Server to

see it. When I try and discover it on the HP Insight server, it comes back with no data. I have my script automating everything. It

is calling the hpmgmt.conf file with my pre-configured settings, I have my snmpd service running, the incoming port 2381 for hpim is open and

the outgoing port 280 is open for sim-cert. Is there anything else that I need to do in order for my Insight server to see my host?

Thanks,

J

0 Kudos
1 Solution

Accepted Solutions
Texiwill
Leadership
Leadership

Hello,

Actually the only necessary port is 2381, 2301 is insecure and should never be used. I use the 7.9.1 agents with no issues, you do have to make sure the snmp settings are proper however. Port 2381 (2301) is for the system management homepage and HPSIM (HPIC) knows to try port 2381. Just make sure it is allowed in your firewall settings. That is most likely the cause of the issue.


Best regards,

Edward L. Haletky

VMware Communities User Moderator

====

Author of the book 'VMWare ESX Server in the Enterprise: Planning and Securing Virtualization Servers', Copyright 2008 Pearson Education. As well as the Virtualization Wiki at http://www.astroarch.com/wiki/index.php/Virtualization

--
Edward L. Haletky
vExpert XIV: 2009-2022,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill

View solution in original post

0 Kudos
6 Replies
admin
Immortal
Immortal

I thought the HP Agents for 3.5 had not yet been released! hence I have not installed it yet.

0 Kudos
TomHowarth
Leadership
Leadership

here are a few links to some threads on Insight manager installation, they are 3.0.x based, but the principle should be the same.

http://communities.vmware.com/thread/56837

this might be teaching you to suck eggs but have you verified that the ports are open on the host

Tom Howarth

VMware Communities User Moderator

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
J_Wright
Enthusiast
Enthusiast

According to the HP website, the newest agent (7.9.1) works with ESX 3.5

0 Kudos
mittim12
Immortal
Immortal

Have you checked the snmpd.conf file to make sure your settings were added? I have it installed using the same incoming and outgoing ports as you and everything works great in my environment.






If you found this or any other post helpful please consider the use of the Helpfull/Correct buttons to award points

dandeane
Enthusiast
Enthusiast

It seems that the HPSIM agent script does not include the line to open port 2301 which is what is needed to talk back to the SIM server. If you execute esxcfg-firewall -o 2301,tcp,in,hpsim from the COS and then add the host into HPSIM you should be good to go.

0 Kudos
Texiwill
Leadership
Leadership

Hello,

Actually the only necessary port is 2381, 2301 is insecure and should never be used. I use the 7.9.1 agents with no issues, you do have to make sure the snmp settings are proper however. Port 2381 (2301) is for the system management homepage and HPSIM (HPIC) knows to try port 2381. Just make sure it is allowed in your firewall settings. That is most likely the cause of the issue.


Best regards,

Edward L. Haletky

VMware Communities User Moderator

====

Author of the book 'VMWare ESX Server in the Enterprise: Planning and Securing Virtualization Servers', Copyright 2008 Pearson Education. As well as the Virtualization Wiki at http://www.astroarch.com/wiki/index.php/Virtualization

--
Edward L. Haletky
vExpert XIV: 2009-2022,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos