server_team
Enthusiast
Enthusiast

ESXPatcher Error

Hi

I am trying to bring my ESX servers up to date, and am trying to patch them using ESXPatcher, and am getting the following error

\----


ERROR: Invalid repository at http://10.149.197.2:5000/patches/3.0.1/ESX-1000039/:

INFO: Make sure you have file: or http: prepended to the URL.

Error 10: Repo or descriptor not reachable

There was an Error in installtion from Patch:ESX-1000039 with Errorcode: 10

\----


the only thing I could find was to open the firewall to allow outgoing which I duly did but to no avail. Any suggestions would be greatly appreciated.

Thanks

0 Kudos
3 Replies
rabittom
Contributor
Contributor

probably some stupid questions but we have to start analyzing from the lower layers...

\- 10.149.197.2 is reachable from SC via ping?

\- did you open port 5000?

\- is a server running on 10.149.197.2 - what happens if you type in the URL in your browser?

regards

gernot

Message was edited by:

rabittom

0 Kudos
server_team
Enthusiast
Enthusiast

Hi gernot

thanks for the input.

10.149.197.2 is the VC, and I have esxPatcher on the VC, so

yes I can ping it

there are no firewalls on the VC

the firewall I opened was on the ESX server

I think I'm going to come back to this one at a later date, I see there is a role up patch, so I am now putting on ESX3.0.2 and VC2.0.2, Keeping ESX, VC and tools up to date is proving to be a pain. Too many patches, reboots and not centralised enough, in my opinion.

Regards

Pete

0 Kudos
rabittom
Contributor
Contributor

Hi Pete,

3.0.2 is a good choice! I've updated all our hosts (40 all around the world) during the last week and beside the issue with the slow smb-connection from the SC there everything runns well.

If you do not have the pressure to do the update I would recommend to wait until VMWorld is over. There are some rumours about 3.1 with a integrated patching-solution a la shavlik..

regards

gernot

0 Kudos