Schorschi
Expert
Expert

Deploy ESX OS 3.0.1 with HP iLO and Dell RAC?

We have gotten HP iLO2 to work for HP C-Class blades, but can't seem to get ESX OS 3.0.1 to work with DRAC. Specifically, we use a configuration diskette that has a kickstart file that is highly customized. We have an environment where we can NOT use a network based build and must use the kickstart on floppy or usb-drive. But the DRAC virtual floppy does not seem to be referenced by anaconda by /dev/fd0? Any one know what device name it is?

esx ks=hd:fd0/ks.cfg (typical floppy)

or

esx ks=hd:sdb/ks.cfg (where the usb flash drive is sdb or sometimes sdc depending on the make/model, or USB floppy)

These work fine, but with the virtual floppy on DRAC we just can not seem to get anaconda to see it.

Anyone get this working?

0 Kudos
6 Replies
msmenne17
Enthusiast
Enthusiast

try /dev/fd1.

DRAC works differently than iLO. iLO redirects/replaces the existing device mappings. DRAC simply adds a virtual floppy/virtual CD-rom.

Michael

0 Kudos
Schorschi
Expert
Expert

Actually, the Virtual Floppy on DRAC 4 and 5 turns out to be 'hde' and for the Virtual Cdrom, 'hdf' of all things.

0 Kudos
oss
Contributor
Contributor

Hi folks

I am having a similar issue. I can't find what the virtual floppy device is using the DRAC 5 on a PE 2950. Could you please put up the full path that you used with the installer i.e:

esx KS=?????? method=cdrom

Any assistance would be much appreciated.

0 Kudos
Schorschi
Expert
Expert

In my case...

boot: esx text ks=hd:hde/ks.cfg

0 Kudos
oss
Contributor
Contributor

Thanks for that. In my case it maps to sdc which is a little strange but seems to work ok with:

esx ks=hd:sdc/ks.cfg

0 Kudos
Schorschi
Expert
Expert

Yeah, hde boots fine, but for some odd reason it is inconsistent, and does not remount hde in my %post script when I need it to do so. My %post script logs what it does and writes back to the read/write media where ks.cfg was orignally. Of course when using a simple floppy (fd0) this works, but with RAC, it appears the floppy image is only read only? Where iLO is read/write enabled. Unless I can write back to the RAC virtual floppy, this eliminates my detailed logging.

0 Kudos