ruffy
Contributor
Contributor

Change IP of Service Console

Jump to solution

Hi, when I try to change the IP Adress and Gateway Adress of the Service Console NIC on the console, i always get this message:

!!!WARNING!!!

Loss of network connectivity may result if invalid parameters are passed to

Add, Delete, Portgroup or IP operations.

and nothing is changed. How is it possible to change the vswif IP ?

I try it with the "esxcfg-vswif" command!

Thanks

0 Kudos
1 Solution

Accepted Solutions
Karunakar
Hot Shot
Hot Shot

Hi,

There are two ways from CLI to chang the IP of service console.

Either to delete the current vswif0 and recreate it using the esxcfg-swif command.

But as you only need to change the ip address of the service console, you can try th below mehtod , changing the entires in the file.

for ip address and netmask of the service console, you can change the entries inthe below file.

/etc/sysconfig/network-scipts/ifcfg-vswif0

and for gateway, hostname use the below file

/etc/sysconfig/network

for dns entries

/etc/resolv.conf

After making all the changes, try to restar the network service.

service network restart

Let me know if you need any more information.

-Karunakar

View solution in original post

0 Kudos
4 Replies
Karunakar
Hot Shot
Hot Shot

Hi,

There are two ways from CLI to chang the IP of service console.

Either to delete the current vswif0 and recreate it using the esxcfg-swif command.

But as you only need to change the ip address of the service console, you can try th below mehtod , changing the entires in the file.

for ip address and netmask of the service console, you can change the entries inthe below file.

/etc/sysconfig/network-scipts/ifcfg-vswif0

and for gateway, hostname use the below file

/etc/sysconfig/network

for dns entries

/etc/resolv.conf

After making all the changes, try to restar the network service.

service network restart

Let me know if you need any more information.

-Karunakar

0 Kudos
dkfbp
Expert
Expert

Hi,

I do it like this from the service console:

"esxcfg-vswif -i x.x.x.x -n y.y.y.y vswif0"

i=new ip address

n=new subnet mask

Then change the gateway address in /etc/sysconfig/network

Then do a "service network restart"

Best regards

Frank Brix Pedersen

Best regards Frank Brix Pedersen blog: http://www.vfrank.org
ruffy
Contributor
Contributor

thanks Smiley Happy

0 Kudos
GuidoR
Contributor
Contributor

Also check the file /etc/hosts for correct ip settings. Otherwise you will get problems with the HA-cluster.

0 Kudos