Contributor
Contributor

update manager 6.5 DSN Error

Currently we are running latest Vmware Update Manager 6.5 patches. When we install Vcenter we didn't install update manager. So now when I try to install update manager I am getting this error during the ODBC DSN configuration.

"The DSN is pointing to an unsupported ODBC driver. Please re-configure you DSN to use one of the supported drivers."

But I checked the DSN and it is using the correct name and version.

Basically update manager can't find the existing vcenter database.

0 Kudos
4 Replies
Leadership
Leadership

Hi,

See this solution if it solves your problem:

DSN pointing to unsupported ODBC driver

ARomeo

Blog: https://www.aleadmin.it/
0 Kudos
VMware Employee
VMware Employee

Hi @SMI2020,

Kindly download the proper Native client from the below link.

ENU\x64\sqlncli.msi

Download Microsoft® SQL Server® 2012 Native Client - QFE from Official Microsoft Download Center

Install the same and take ODBC 64-bit. Create a new System DSN with the newly installed Native Driver. Initiate the VUM installation again.

Regards,

Nirmal Nair

0 Kudos
VMware Employee
VMware Employee

For Windows vCenter 6.5 ; vCenter DB and VUM DB are supposed to be separate DB's with 2 different DSN's for them .

You should use the 64-bit ODBC Native Client (ENU\x64\sqlncli.msi)

Download Microsoft® SQL Server® 2012 Native Client - QFE from Official Microsoft Download Center

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
VMware Employee
VMware Employee

Update Manager DB is installed on seperate instance it does not use the vCenter DB.

With Update Manager installation it gives the sql express edition which you can install for small scale env. where you are using 5 ESxi and 50 VMs.

However for an env. larger that above mentioned configuration it is recommended to use full sql version.

Below articles will provide you guidelines for the installation of Update manager with embedded DB and preperation of the SQL DB if using External.

Update Manager Database Requirements

https://docs.vmware.com/en/VMware-vSphere/6.5/com.vmware.vsphere.update_manager.doc/GUID-F54C006C-C8...

Update Manager with embedded sql express.

https://docs.vmware.com/en/VMware-vSphere/6.5/com.vmware.vsphere.update_manager.doc/GUID-7DB71999-5B...

0 Kudos