ivanerben
Enthusiast
Enthusiast

VMware vSphere Update Manager Check Notification

After upgrade from 6.7 to 7.0U3 we have queued endless tasks 'VMware vSphere Update Manager Check Notification' in multiple vcenters. Update download is working fine.

Is this some bug? Anybody else with this issue?

ivanerben_0-1635846974794.png

 

0 Kudos
6 Replies
JacoAxians040
Contributor
Contributor

Hi, I'm running into the same issue. Found article https://kb.vmware.com/s/article/84214 but it doesn't tell how to connect to the database and if I do it the way I think it is supposed to be done (/opt/vmware/vpostgres/current/bin/psql -U postgres -d VCDB) I get an error message "ERROR: relation "vci_textfiles" does not exist"

Hope someone can jump in

0 Kudos
ivanerben
Enthusiast
Enthusiast

Open support case, fix was different deletion from database, not this.

0 Kudos
danL1979
Contributor
Contributor

I was able to figure out a solution based on these two articles:

How I determined the task was depreciated, but the provided fix did not work: https://kb.vmware.com/s/article/84214 

How I figured out how to edit the tasks directly in the DB: https://kb.vmware.com/s/article/77202 

Step by step of what I did (I chose to disable the task, instead of deleting, just in case):

  1. Enable SSH and shell for your vcenter, and SSH into it, then access the shell:
    shell
  2. Stop the vpxd and vmware-content-library services
    service-control --stop vpxd
    service-control --stop vmware-content-library
  3. Log into the built in DB
    /opt/vmware/vpostgres/current/bin/psql -U postgres -d VCDB
  4. Verify the tasks, and find the id that matches the "VMware vSphere Update Manager Check Notification"
    select scheduledtask_id, name, enabled from vpx_scheduledtask;
  5. Update the scheduled task, and set to disabled (replace with the correct ID for the task, mine was 502, but yours is probably different)
    update vpx_scheduledtask set enabled = 0 where scheduledtask_id = 502;
  6. Verify task is now disabled
    select scheduledtask_id, name, enabled from vpx_scheduledtask;
  7. Exit DB access
    \q
  8. Start the services you turned off previously
    service-control --start vpxd
    service-control --start vmware-content-library
Sooperfly
Contributor
Contributor

Thanks for posting this. Helped me today!

0 Kudos
AmirFrenkel
Contributor
Contributor

Click on the VCenter in the inventory view.

Select: Configure

Under Security: Scheduled Tasks

Select Update Manager Hourly and press Remove

 
kevsterd
Contributor
Contributor

Fixed it for me on a brand new 7.0.3U4 install !

0 Kudos