VCSA 6.7 Update Manager fails to download patch definitions when behind proxy

VCSA Build 9451876

VMware Update Manager, Version = 6.7.0, Build = 9031744

When I test the proxy settings under 'Download Settings', it succeeds for, and fails for (presumably because it gets a 301 Moved Permanently response), but both case use the proxy server successfully.

Clicking 'Download Now' generates no network traffic and shows this task result:

Web sites:; hosting the patch definitions and patches cannot be accessed or have no patch data. Check the Internet connectivity.

Is there anything else I can do to get this working, or am I waiting on an update to fix this?

LOG /var/log/vmware/vmware-updatemgr/vum-server/vmware-vum-server-log4cpp.log:

['miscUtil' 139839201699584 INFO]  [miscUtilPosix, 118] Value for registry.proxy.UseProxy is: 1
['miscUtil' 139839201699584 INFO]  [miscUtilPosix, 118] Value for registry.proxy.ProxyServer is:
['miscUtil' 139839201699584 INFO]  [miscUtilPosix, 118] Value for registry.proxy.ProxyPort is: 8080
['miscUtil' 139839201699584 INFO]  [miscUtilPosix, 118] Value for registry.proxy.ProxyUserName is:
['miscUtil' 139839201699584 INFO]  [miscUtilPosix, 116] Value for registry.proxy.ProxyPassword is: ********
['DownloadMgr' 139839201699584 DEBUG]  [downloadMgr, 549] Url:, Download destination: /tmp/vci6jGU8O
['DownloadMgr' 139839201699584 DEBUG]  [downloadMgr, 400] Inserted download job {139838699463824} to queue
['DownloadMgr' 139839201699584 DEBUG]  [downloadMgr, 420] Current download count: 0
['DownloadMgr' 139839201699584 DEBUG]  [downloadMgr, 436] Current download count: 1
['DownloadMgr' 139839201699584 DEBUG]  [downloadMgr, 442] Adding download job {139838699463824} to scheduler
['DownloadMgr' 139839201699584 DEBUG]  [downloadMgr, 462] Waiting for download job {139838699463824} to finish...
['DownloadMgr' 139839201965824 INFO]  [downloadMgr, 603] Executing download job {139838699463824}, url=
['httpDownload' 139839201965824 ERROR]  [httpDownloadPosix, 649] curl_easy_perform() failed: cURL Error: Couldn't connect to server, Unsupported proxy scheme for '[]:8080'
['DownloadMgr' 139839201965824 ERROR]  [downloadMgr, 629] Executing download job {139838699463824} throws error: curl_easy_perform() failed: cURL Error: Couldn't connect to server, Unsupported proxy scheme for '[]:8080'

Tags (2)
4 Replies

I was experiencing this exact same issue since upgrading our VCSA to v6.5 Build 9451637 (from v6.5 base).

After working with VMware support on this issue for a couple of days, I eventually figured out a solution.. hopefully this help your situation as well.

The proxy string entered in the UI "Proxy Settings" dialog box cannot contain a HTTP:// or HTTPS:// prefix. The version of cURL used in this version of the VCSA/Update manager will not accept this string (hence the "Unsupported Proxy scheme" error you listed above), so it ignores the proxy settings entirely and attempts to connect to the patch repositories directly - which are likely blocked by the firewall.

I cannot be 100% certain that this was a change in Build 9451637... but I swear it worked with the prefix in previous versions!


A quick workaround, download patch offline and upload to VUM.

Find this helpful? Please award points. Thank you !
0 Kudos

I got it working!

I use Windows for my vCenter, after I set my browser with a proxy in the control panel everything worked for Update Manager, and I got all my patches and updates from the internet.

If you use Appliance, maybe try this one in the shell(not sure though):

0 Kudos

Had the same issue, needed to remove http/https from the proxy adress then it worked... (i know that this worked before 6.7 upgrade).

Also i restarted the update manager service after changes. (dont know if it is necessary)

0 Kudos