stratolynne
Contributor
Contributor

Trying to use Functional account to startup VMware Update Manager 5.0

I'm trying to use a Functional account to startup VMware Update Manager 5.0 with external SQL database.

When I try to start up Update Manager Service with this new account I get the following error:

  Services

   

    Windows could not start the VMware vSphere Update Manager Service service on Local Computer.

    Error 5: Access is denied.

There is not an Update Manager log.

What are the privileges required for this account so it will work?

Anyone done this and have some hints, tips, etc?

0 Kudos
3 Replies
mcasekar
Enthusiast
Enthusiast

I hope the below details may helps you to resolve your issue.

How to Configure User Rights

If the right to log on as a service is revoked for the specified user account, restore the right by performing the following steps:

Domain Controller

If the user is in an Active Directory domain:

  1. Start the Active Directory Users and Computers Microsoft Management Console (MMC) snap-in.
  2. Right-click the Organizational Unit (OU) in which the user right to log on as a service was granted. By default, this is in the Domain Controllers OU.
  3. Right-click the container, and then click Properties.
  4. On the Group Policy tab, click Default Domain Controllers Policy, and then click Edit. This starts Group Policy Manager.
  5. Expand the Computer Configuration object by clicking the plus sign (+) next to the policy object. Under the Computer Configuration object, expand Windows Settings, and then expand Security Settings.
  6. Expand Local Policies, and then click User Rights Assignment.
  7. In the right pane, right-click Log on as a service, and then click Security.
  8. Add the user to the policy, and then click OK.
  9. Quit Group Policy Manager, close Group Policy properties, and then close the Active Directory Users and Computers MMC snap-in.

Member Server

If the user is a member of a stand-alone member server:

  1. Start the Local Security Settings MMC snap-in.
  2. Expand Local Policies, and then click User Rights Assignment.
  3. In the right pane, right-click Log on as a service, and then click Security.
  4. Add the user to the policy, and then click OK.
  5. Close the Local Security Settings MMC snap-in.

How to Configure Service Logon Information

To configure the password for the specified user account to match the current password for that user, use the following steps:

  1. Click Start, point to Settings, click Control Panel, and then double-click Administrative Tools.
  2. Double-click Services.
  3. Right-click the appropriate service, and then click Properties.
  4. On the Log On tab, change the password, and then click Apply.
  5. On the General tab, click the Start to restart the service.
  6. Quit the Services tool.
Regards| Rajasekar.N| "If you find this answer useful, please consider awarding points by marking the answer correct or helpful"
0 Kudos
stratolynne
Contributor
Contributor

Log on as a service was already enabled.  Any other ideas?

Thanks.

0 Kudos
VIR2AL3X
Enthusiast
Enthusiast

stratolynne‌ Hello, I know this is a fairly old thread but in order to resolve this, in addition to granting the "Log on as a service" permission to the user account, ensure you have also added the user account to the local administrators group on the vCenter Server.  I hope this helps!

0 Kudos