Contributor
Contributor

One or more VIBs mapping to Bulletin VMW-ESX-6.0.0-ixgben-1.7.15 have dependencies not installed on the host:

Hi,

I imported driver vib for ixgben driver version 1.7.15 (VMware Compatibility Guide - I/O Device Search) into 6.5 VUM patch repository (VCSA). Then I added this vib to a custom baseline, I did the same a while ago for version 1.7.10, but can't remember if I had same problems back then.

pastedImage_3.png

But I'm unable to install this vib,

pastedImage_4.png

vmware-vum-server-log4cpp.log:

[2019-05-28 12:24:48:693 'HostUpdateDepotManager' 140273770456832 INFO]  [scanHost20, 1436] One or more VIBs mapping to Bulletin VMW-ESX-6.0.0-ixgben-1.7.15 have dependencies not installed on the host: xxxxxxxx (entity: host-39) and not part of the bulletin, marking as 'UNKNOWN' for DVS scan

I'm able to install the vib with cli without problems, only VUM is not liking it. Any idea why and how to resolve this? Using cli to rollout his vib to a larger number of hosts is not the most efficient way.

# esxcli software vib install -v /tmp/ixgben-1.7.15-1OEM.600.0.0.2768847.x86_64.vib

Installation Result

Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.

Reboot Required: true

VIBs Installed: INT_bootbank_ixgben_1.7.15-1OEM.600.0.0.2768847

VIBs Removed: INT_bootbank_ixgben_1.7.10-1OEM.600.0.0.2768847

VIBs Skipped:

# esxcli software vib get -n ixgben

INT_bootbank_ixgben_1.7.15-1OEM.600.0.0.2768847

Name: ixgben

Version: 1.7.15-1OEM.600.0.0.2768847

Type: bootbank

Vendor: INT

Acceptance Level: VMwareCertified

Summary: Network driver for Intel(R) 10 Gigabit NIC

Description: Native ixgben network driver for VMware ESXi

ReferenceURLs:

Creation Date: 2019-03-29

Depends: vmkapi_2_3_0_0

Conflicts:

Replaces:

Provides:

Maintenance Mode Required: False

Hardware Platforms Required:

Live Install Allowed: False

Live Remove Allowed: False

Stateless Ready: True

Overlay: False

Tags: module, driver

Payloads: ixgben

esxcli software vib get -n ixgben

INT_bootbank_ixgben_1.7.10-1OEM.600.0.0.2768847

Name: ixgben

Version: 1.7.10-1OEM.600.0.0.2768847

Type: bootbank

Vendor: INT

Acceptance Level: VMwareCertified

Summary: Network driver for Intel(R) 10 Gigabit NIC

Description: Native ixgben network driver for VMware ESXi

ReferenceURLs:

Creation Date: 2018-09-06

Depends: vmkapi_2_3_0_0

Conflicts:

Replaces:

Provides:

Maintenance Mode Required: False

Hardware Platforms Required:

Live Install Allowed: False

Live Remove Allowed: False

Stateless Ready: True

Overlay: False

Tags: module, driver

Payloads: ixgben

0 Kudos
3 Replies
Enthusiast
Enthusiast

We got the same issue for 1.7.17 and 1.7.20 on 6.5 U3 hosts and were also able to patch using get-excli command whitout any force or tricky options.

Did you find out more about this?

0 Kudos
Contributor
Contributor

No, I closed the ticket at VMware after I was asked to reinstall VUM for the third time without success.

0 Kudos
Enthusiast
Enthusiast

reinstall VUM on a VCSA ?? i got a ticket opened now, i'll let you know if you're interested but that doesn't start well, they asked me to check with my HW vendor to uninstall some vibs because i don't use all of my network cards...

0 Kudos