domainadmin
Contributor
Contributor

Error "A web exception has occurred during file upload" when trying to import ESXi image file into Update Manager

I'm encountering this error and not sure how to fix, I'm quite new to vCenter so please bear with me.

I'm trying out vCenter 5.1 with Update Manager 5.1 right now.  No license key has been entered and I still have 50 odd days to try it out.

2 ESXi hosts are being managed by this vCenter, and they're both running ESXi 4.0

I'm looking to use Update Manager to try to upgrade the ESXi 4.0 hosts to ESXi 5.1

I downloaded the image file VMware-VIMSetup-all-5.1.0-799735.iso from VMWare website, and is looking to import it using the Update Manager so I can update the ESXi hosts, but I keep on getting the error:

File name:     VMware-VIMSetup-all-5.1.0-799735.iso

Failed to transfer data

Error was: A web exception has occurred during file upload

I tried importing it by using vSphere client to connect to vCenter server both remotely and locally, with firewall disabled.

I've read http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=102660...

I've disabled firewall, and there is no anti-virus program on the server.  I've also restarted the machine several times, to no avail, I didn't reinstall update manager because the whole Windows and VCenter installations are clean from scratch.

I logged into the vSphere Client using Active Directory credentials, and I've made all Domain Admins (which my account is a member of) part of the administrator group on the vCenter server. I can't log in using admin@System-Domain because it tells me I don't have permissions for it, I still haven't really had the chance to figure out why that is and not sure if that makes a difference.

Also, I'm fairly certain I'm using the right image file, as I've burned some DVD's used that image file to upgrade some other ESXi hosts.  Unless there's a special image file I need to download?

I'm at lost on what I can do to make it work.  Please advise.

Thanks.

2 Replies
a_p_
Leadership
Leadership

The ISO file you mentioned is the one for vCenter Server. What you need is the "VMware-VMvisor-Installer-5.1.0-799733.x86_64.iso" (or VMware-VMvisor-Installer-201210001-838463.x86_64.iso) for the ESXi host.

André

chrisexline
Contributor
Contributor

I had this same issue and this worked for me.  Thanks.

0 Kudos