BonnoB
Enthusiast
Enthusiast

Cannot remediate host because of HA

Hi,

Using vCenter 5.1 u1 and ESXi hosts 5.1 u1

I want to patch my ESXi hosts for the first time so it may be something in the setup but.... I would not know what. The whole setup was done by someone who has set up several 5.1 installations. **

I have a cluster of 3 hosts, I put one in maintenance mode. All VMs have been moved to the other 2 hosts and while the host went into maintenance mode the details column showed "Disabling vSphere HA on ...." So I assume that this host is no longer part of the HA machines in the cluster.

When I want to initiate the remediation of the host I get:

Cannot remediate host <name> because it is a part of a HA admission control enabled cluster

Which is funny as this host is no longer a member of the HA group in the cluster.

According to VMware KB: An ESX/ESXi host remediation fails with the error: No supported hosts found for remediate...

I could simple disable HA on the cluster, remediate the host and then enable HA once more.

It is the only relevant KB article I could find but.... somehow that does not feel like it is the proper solution, nor does it feel like it describes my problem as I allready put the host in maintenance mode and HA should not be a problem any more.

Anyone know of a better solution before I try disabling HA on the cluster?

**  I may be a VCP 4.1 but there were too many changes for me from 4.1 to 5.1u1 to feel comfortable doing this myself. And I am glad I did it that way as even he ran into problems that were not covered yet in a KB because of the fact that we put the vCenter server on Windows 2012.

2 Replies
pratjain
VMware Employee
VMware Employee

When you remediate check the option "Disable High Availability admission control if it is enabled for any of the selected clusters"in Edit the cluster remediation options.

upgrade_esxi5_019.jpg

.

Regards, PJ If you find this or any other answer useful please mark the answer as correct or helpful.
JustinPH
Contributor
Contributor

Thank you for that! Been so long since I upgraded our HOSTS I had forgotten I needed to allow that Smiley Happy

0 Kudos