alstarian123
Contributor
Contributor

Cannot download software packages from patch source, check the events and udpdate manager logs

Jump to solution

Hi All,

I have performed a host upgrade of my host from 5.5 o 6.5 using the host upgrade feature in the vpshere client 6.5 and it has completed successfully and then went ahead and updated the "Critical Host Patches" baseline and applied the outstanding patches as well. However I am facing an issues applying the outstanding patches in the "Non Critical Host Patches" baseline. I have like 11 outstanding patches in them and no matter what I try I cant get them to download and in my vpshere client i see the error "Cannot download software packages from patch source, check the events and udpdate manager logs".

I check the esxupdate.log, and tailed the last 20 lines as you can see below.

updatemgr.JPG

I cant seem to figure that out. I downloaded and applied the critical patches but not the other baseline...

Any Ideas?

-A

0 Kudos
1 Solution

Accepted Solutions
hussainbte
Expert
Expert

Kindly be aware that ESXi patches associated with VMSA-2018-0004 have been pulled down from the online and offline portal.

As per the Below KB article

https://kb.vmware.com/s/article/52345

check with your hardware vendor

If you found my answers useful please consider marking them as Correct OR Helpful Regards, Hussain https://virtualcubes.wordpress.com/

View solution in original post

0 Kudos
5 Replies
hussainbte
Expert
Expert

In some cases the existing patches if rolled over for some reason might report those kind of messages.

I suggest you to take check the actual patch details from vmware KB and check if it is superseded by any other patch or still available.

If that is the case you can check for the superseded patch and confirm if it is installed or no.

If you found my answers useful please consider marking them as Correct OR Helpful Regards, Hussain https://virtualcubes.wordpress.com/
0 Kudos
alstarian123
Contributor
Contributor

Hi,

So what I did was I started applying the patches in batches of 2-3 from the oldest. I had about 11 outstanding patches as non critical. So when i started doing that the patches started working and the host started accepting that. So i got all the way to the top and out of 11 I was able to apply 10. On the last outstanding patch I got the error "Cannot download software packages from patch source" and this patch is the most recent patch from Vmware which address the CPU vulnerabilities on Intel bases processors released on the 9th of January 2018. The patch number is "ESXi650-201801401-BG". So this patch needs to be applied and as a matter of fact I have applied this on a different hosts under a different vcentre, and they work with no issues. So its the update manager in this vcenter that is messing this up.

As of now I dont know what it is, I will keep looking, but as of now I have isolated the issue to one patch that is causing this..

-A

0 Kudos
hussainbte
Expert
Expert

Kindly be aware that ESXi patches associated with VMSA-2018-0004 have been pulled down from the online and offline portal.

As per the Below KB article

https://kb.vmware.com/s/article/52345

check with your hardware vendor

If you found my answers useful please consider marking them as Correct OR Helpful Regards, Hussain https://virtualcubes.wordpress.com/

View solution in original post

0 Kudos
alstarian123
Contributor
Contributor

Thanks a lot for pointing me in the right direction!

0 Kudos
NRay
Contributor
Contributor
0 Kudos