anlyvm
VMware Employee
VMware Employee

Can not install vSphere update manager client plug in in vsphere web client (flex)

Hi, when I access vCenter via vSphere client (html5), I can access vSphere update manager as the server and client are

automatically installed. However, when I access the same vCenter via vSphere web client (flex), I cannot acess vSphere

update manager. The service is running, but the client plug in is not installed. I clicked "check for new client plug-ins",

and nothing happened. Is there anything I am missing or configuration that I need to enable? Thanks!

According to vsphere 6.7 document, "The Update Manager client plug-ins for the vSphere Client and the vSphere Web Client require no installation. "

So how to access vSphere update manager in flex client? Thanks!

Tags (1)
0 Kudos
7 Replies
msripada
Virtuoso
Virtuoso

It should be by default enabled. However if it is missing, we need to vsphere_client_virgo.log from /var/log/vmware/vsphere-ui/logs location to identify if there is an issue loading the plugin.

Kindly attach the logs please in your next reply

Thanks,

MS

0 Kudos
anlyvm
VMware Employee
VMware Employee

Hi, thanks for your response. How do I attach file here? I guess I need to attach the file under vsphere-client/logs directory instead of vsphre-ui./logs directory, right?

0 Kudos
msripada
Virtuoso
Virtuoso

yes, if you are having issues in flex then we need the vsphere-client logs.. sorry my bad on the location.

You can give a shot by trying the steps in below kb after taking snapshot of vcenter

VMware Knowledge Base

Thanks,

MS

0 Kudos
anlyvm
VMware Employee
VMware Employee

Hi, msripada

Thanks for your suggestion. I checked the log and didn't find similar wording. However, I did remove the caching data

following KB article. I still cannot see “update manager" showed in Home page. Thanks!

0 Kudos
msripada
Virtuoso
Virtuoso

ok, can you share me the latest vsphere-client-virgo.log ..

Thanks,

MS

0 Kudos
anlyvm
VMware Employee
VMware Employee

Hi msripada,

Thank you! I found the attach function. Here is the log.

Thanks,

Hua

0 Kudos
msripada
Virtuoso
Virtuoso

Thanks for the logs

[2019-02-06T22:33:59.426Z] [WARN ] ice-extension-mngr-pool-1347 70002211 100161 200005 c.vmware.vise.vim.directory.extensions.DirectoryExtensionManager  Detected an invalid signature for plugin: com.vmware.fallback.mixed:6.5.0 - com.vmware.vise.extensionfw.signing.PluginSignatureException: No META-INF/MANIFEST.MF entry found in the plugin zip file.

[2019-02-06T22:33:59.427Z] [INFO ] ice-extension-mngr-pool-1347 70002211 100161 200005 com.vmware.vise.extensionfw.impl.PackagesDeployer                 Could not resolve dependencies for plugins packages: [ com.vmware.fallback.mixed:6.5.0 requires: [ com.vmware.vsphere.client lessThan 6.0.2 ]; ]; 

[2019-02-06T22:33:59.428Z] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       Started validation of OSGi bad practices.

[2019-02-06T22:33:59.428Z] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       OSGi validation skipped for plugin package com.vmware.fallback.mixed:6.5.0. It is not deployed.

[2019-02-06T22:33:59.428Z] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       Finished validation of OSGi bad practices.

[2019-02-06T22:33:59.430Z] [WARN ] ice-extension-mngr-pool-1348 70002211 100161 200005 c.vmware.vise.vim.directory.extensions.DirectoryExtensionManager  Detected an invalid signature for plugin: com.vmware.vum.client:6.8.4.00000 - com.vmware.vise.extensionfw.signing.PluginSignatureException: The certificate common names (CN) [test] do not contain the expected one.

[2019-02-06T22:33:59.430Z] [WARN ] ice-extension-mngr-pool-1348 70002211 100161 200005 com.vmware.vise.extensionfw.impl.PackageManifestParser            Plugin version mismatch for com.vmware.vum.client between the plugin registration info (6.8.4.00000)and the version specified in plugin-package.xml (6.8.2). The registration version will be used but you should keep them in sync.

[2019-02-06T22:33:59.431Z] [ERROR] ice-extension-mngr-pool-1348 70002211 100161 200005 com.vmware.vise.extensionfw.impl.PackagesDeployer                 Could not resolve dependencies for plugins packages: [ com.vmware.vum.client:6.8.4.00000 requires: [ com.vmware.vsphere.client.html greaterOrEqual 6.8.2 ]; ];

[2019-02-06T22:33:59.431Z] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       Started validation of OSGi bad practices.

[2019-02-06T22:33:59.431Z] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       OSGi validation skipped for plugin package com.vmware.vum.client:6.8.4.00000. It is not deployed.

I need to verify this same again but which plugin version has the registration which may not be compatible.

Can you try to re-register the VUM using the steps in below article and share the results

How do i reregister Update manager to my vcsa??

Note : Please take vcenter backup and snapshot before trying the above steps

Thanks,

MS

0 Kudos