msalahshur
Contributor
Contributor

enable embedded harbor registry failure

Hello to all


I installed tanzu on vsphere 7  using nsx-t. When I enable the embedded harbor registry in the supervisor cluster, I have the following problem.

supervisor clustersupervisor clustertanzu versiontanzu version03.JPG04.JPG05.JPGnsx-tnsx-t

I set the value of MTUs to 1600 and None of the control plane vm has a problem. 
I deactivated the workload once and reinstalled it.

Thank you for your attention.

0 Kudos
5 Replies
eric2015
VMware Employee
VMware Employee

It looks there might be some issue with networking. Could you run `kubectl describe <harbor-core-pod> -n <harbor-ns>` on the harbor core pod or the harbor database pod? This would provide more details why the pod couldn't come up.

0 Kudos
rguske
VMware Employee
VMware Employee

Hi, does this issue still exist? Sorry for the late reply.
Twitter: @vmw_rguske
LinkedIn: https://www.linkedin.com/in/robert-guske-830853111/
0 Kudos
Boyd94596
Contributor
Contributor

Procedure
In the vSphere Client, browse to the vCenter cluster where Workload Management is enabled.
Select Configure.
Select Supervisor Cluster.
Select Image Registry.
Click Enable Harbor.
Select the Storage Policy for placement of container images.
Click OK to complete the process.

0 Kudos
McDonald43452
Contributor
Contributor

Hi,

Note:
To use the embedded Harbor Registry, you must deploy the Supervisor Cluster with NSX-T Data Center as the networking solution. See Configuring NSX-T Data Center for vSphere with Tanzu.

Procedure
In the vSphere Client, browse to the vCenter cluster where Workload Management is enabled.
Select Configure.
Select Supervisor Cluster.
Select Image Registry.
Click Enable Harbor.
Select the Storage Policy for placement of container images.
Click OK to complete the process.

mycenturahealth

0 Kudos
GaborT
Contributor
Contributor

Hello!

We also had the same problem, after weeks of investigation it turned out that the names of the esxi hosts have capital letters. After renaming them all to lowercase names and restarting the hosts, I was able to enable the Harbor

Regards,

G