sorcerer12101
Enthusiast
Enthusiast

timeout en virtualcenter 2.5 al añadir storage

Buenos días,

Tenemos en la empresa una infraestructura virtual con Virtualcenter 2.5 y 10 hosts esx 3.5, funcionando sin problemas desde algunos años. Desde hace unas semanas tenemos problemas al añadir storage nuevo para crear datastores ya que al pinchar en Add Storage, en Configuration/Storage ya un error de timeout y no es posible hacerlo. Investigando un poco hemos visto que existen confictos con las reservas iSCSI, he revisado varios KB de vmware que hacen referencia a este tipo de problema pero sin resultados. En este KB

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100229... se indica el comando a ejecutar para localizar y eliminar bloqueos de LUN en un host en concreto pero no ha aparecido ningúno en ningún host. En otro KB hace referencia a los agentes de HP pero después de realizar lo indicado tampoco funciona. He revisado logs pero no veo nada que pueda darme alguna pista. Adjunto los logs que indican el problema con las reservas iSCSI. Se indican problemas con unas 10 LUN, todas ellas conectadas por RDM. Agradecería cualquier ayuda ya que estoy atascado y necesito darle una solución. Muchas gracias.

Dec 20 17:09:43 bpcs-maesxpr-01 vmkernel: 170:22:08:37.293 cpu8:1049)WARNING: SCSI: 119: Failing I/O due to too many reservation conflicts

Dec 20 17:09:43 bpcs-maesxpr-01 vmkernel: 170:22:08:37.293 cpu8:1049)WARNING: SCSI: 255: status SCSI reservation conflict for vml.02002d00006006016010f4270002

f2c7cc69a4df11524149442035. residual R 919, CR 0, ER 3

VMWARE: Device that would have been attached as scsi disk sdaf at scsi1, channel 0, id 0, lun 32

Has not been attached because this path could not complete a READ command eventhough a TUR worked.

result = 0x18 key = 0x0, asc = 0x0, ascq = 0x0

VMWARE: Device that would have been attached as scsi disk sdaf at scsi1, channel 0, id 0, lun 32

Has not been attached because it is a duplicate path or on a passive path

scsi1 (0,0,33) : RESERVATION CONFLICT

scsi1 (0,0,33) : RESERVATION CONFLICT

scsi1 (0,0,33) : RESERVATION CONFLICT

scsi1 (0,0,33) : RESERVATION CONFLICT

scsi1 (0,0,33) : RESERVATION CONFLICT

scsi1 (0,0,33) : RESERVATION CONFLICT

VMWARE: Device that would have been attached as scsi disk sdaf at scsi1, channel 0, id 0, lun 33

Has not been attached because this path could not complete a READ command eventhough a TUR worked.

result = 0x18 key = 0x0, asc = 0x0, ascq = 0x0

VMWARE: Device that would have been attached as scsi disk sdaf at scsi1, channel 0, id 0, lun 33

Has not been attached because it is a duplicate path or on a passive path

David Perez Ferrer - VCP4 / VCP5 Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
Tags (1)
0 Kudos
6 Replies
MiguelAngelAlon
Enthusiast
Enthusiast

Hola! Creo que deberías hacer un reset de tus controladores de la San y si el problema persiste entonces en segundo lugar un reinicio del software iSCSI desde la Service Console con vmkfstools.

Saludos, Miguel Angel Alonso, Virtualization Solution Architect My Company: http://www.jmgvirtualconsulting.com MyBlog:http://www.josemariagonzalez.es/author/miguel-angel-alonso-pomar My Linked:http://www.linkedin.com/pub/miguel-angel-alonso/30/4a7/5a5 My Twitter:https://twitter.com/#!/MiguelAAlonso
0 Kudos
MiguelAngelAlon
Enthusiast
Enthusiast

El comando seria vmkfstools -L lunreset por si lo necesitas

Saludos, Miguel Angel Alonso, Virtualization Solution Architect My Company: http://www.jmgvirtualconsulting.com MyBlog:http://www.josemariagonzalez.es/author/miguel-angel-alonso-pomar My Linked:http://www.linkedin.com/pub/miguel-angel-alonso/30/4a7/5a5 My Twitter:https://twitter.com/#!/MiguelAAlonso
0 Kudos
MiguelAngelAlon
Enthusiast
Enthusiast

Además te dejo este Lina que creo que te va a ayudar muchísimo

http://blog.vmpros.nl/2010/12/23/vmware-scsi-reservation-conflicts/

Saludos, Miguel Angel Alonso, Virtualization Solution Architect My Company: http://www.jmgvirtualconsulting.com MyBlog:http://www.josemariagonzalez.es/author/miguel-angel-alonso-pomar My Linked:http://www.linkedin.com/pub/miguel-angel-alonso/30/4a7/5a5 My Twitter:https://twitter.com/#!/MiguelAAlonso
0 Kudos
sorcerer12101
Enthusiast
Enthusiast

Gracias por tus respuestas,

El tema del reset de las LUNs es una de las cosas que ya había mirado, de todos modos a raiz de tu respuesta he buscado e identificado los nombres administrativos de las LUNs con las que tenemos el problema y les he ejecutado el lunreset, a pesar de que no aparecia ningún bloqueo. Después he hecho un rescan pero no he conseguido nada. Me faltaría el tema de las controladoras de la SAN, esto se lo he solicitado al departamento correspondiente y a ver si me hacen caso ya que está en otro pais y a veces es dificil gestionar ciertas cosas. Ya te iré contando. Gracias de nuevo.

David Perez Ferrer - VCP4 / VCP5 Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
MiguelAngelAlon
Enthusiast
Enthusiast

Gracias a ti amigo por intentarlo, solo espero que puedas dar carpetazo al asunto lo mas rápido que puedas. De todas maneras estaré atento a como va evolucionando tu problema.

Un saludo

Saludos, Miguel Angel Alonso, Virtualization Solution Architect My Company: http://www.jmgvirtualconsulting.com MyBlog:http://www.josemariagonzalez.es/author/miguel-angel-alonso-pomar My Linked:http://www.linkedin.com/pub/miguel-angel-alonso/30/4a7/5a5 My Twitter:https://twitter.com/#!/MiguelAAlonso
0 Kudos
sorcerer12101
Enthusiast
Enthusiast

Buenos días,

Sigo intentando resolver el problema. Hemos reiniciado los servidores ESX y hemos mejorado algo el tiempo de respuesta pero sigue siendo muy alto y no vemos por donde puede estar la solución. Mirando mas opciones estamos barajando la posibilidad de una "saturación" en el cluster. Actualmente tenemos conectadas 109 LUN,s al cluster y pensamos que a lo mejor son demasiadas para un cluster HA/DRS en la versión 3.5. Podrías/podríais darme vuestra opinión? ¿Cuales son los máximos en este aspecto para la versión 3.5? Tenemos 17 host ESX y las LUN,s están divididas entre datastores y asignaciones por RDM físicas a las máquinas virtuales. Gracias.

Un saludo,

David Perez Ferrer - VCP4 / VCP5 Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos