sbdonosti
Enthusiast
Enthusiast

iscsi openfile 2.2 y ESX 3.5 entorno Demo

Buenas tardes a todos

Llevaba tiempo intentando montar un entorno laboratorio para demos de esx y finalmente he creado el siguiente entorno:

Tres ordenadores, que se distrubuyen de la siguiente forma:

2 PC para instalar esx 3.5

1 para instalar windows 2003 server con vmware SERVER

En este ultimo ordenador he creado 2 maquinas virtuales:

1 windows 2003 que realizara la funcion de Virtual center, servidor de licencias y en un futuro VCB.

1 maquina virtual con Openfiler ver 2.2 con ISCSI para conseguir el almacenamiento compartido que se requiere para Vmotion etc

Caracteristicas de los PC

El unico elemento "especial" que he requerido para el correcto funcionamiento de la demo, es la compra de 2 tarjetas de red intel modelo 82541PI gigabyte ethernet controler . Por lo demas, son pc clonicos, con 4GB de memoria y dual core, ya que tampoco necesito de momento mucho mas para cargar un par de VM en cada ESX.

A partir de aqui, he creado el cluster con los dos ESX, he activa HA y DRS.

El caso es que desde uno de los ESX, veo perfectamente a traves de la configuracion Iscsi la LUN creada en el opeonfiler, incluso la he formateado en VMFS y he creado una maquina virtual. Sin embargo, desde el otro ESX no hay manera de conseguir que vea el openfiler, si hacer ping, pero por mucho que configuro las propiedades iscsi del host, al rescanear no me aparecen ni un solo target y menos ninguna de las 2 LUN creadas en el openfiler.

No veo donde puedo mirar para conseguir alguna pista de lo que pueda estar sucediendo, alguna ayuda?

gracias a todos de antemano

saludos

0 Kudos
3 Replies
sbdonosti
Enthusiast
Enthusiast

Buenos dias a todos

Solucionado el problema, tengo un amigo nuevo en el entorno de Virtualizacion llamado FIREWALL, que desde hoy, tengo que tenerlo en mi cabeza, ya que era el responsable de cortarme la comunicacion ISCSI, y el que no permitía que el host viera ningun target. He abierto el firewall con esxcfg-firewall --allowIncoming y esxcfg-firewall --allowOutgoing y me ha funcionado correctamente,

saludos a todos

0 Kudos
kailess1
Enthusiast
Enthusiast

Buenas sbdonosti

Lo que se me ocurre es que a la hora de dar visibilidad a los ESX la lun del openfiler se la hayas dado solo a un equipo o te falte añadir alguna de las ip's ya sea de la SC o del Vmkernel del host que te está fallando

Para que el tema funcionase tanto la SC auxiliar que hemos levantado como el interfaz de Vmkernel del iSCSI tienen que poder ver la lun, en mi opinión la mejor forma de hacer esto es usar un rango de red en exclusiva para este servicio y darle visibilidad a todo ese rango en la configuración de la lun mejor que ir ip a ip (no sé si lo tienes así).

Yo tengo esta configuración:

Esx1 --- Sc auxiliar 193.148.150.1 Vmkernel 193.148.150.2

Esx2 -


Sc auxiliar 193.148.150.3 Vmkernel 193.148.150.4

Luego en openfiler en la parte de Local network configuration .

Y en la configuración de la lun que quiero publicar

Revisa la configuración de red de tus esx y la configuración del openfiler para asegurarte de que los dos equipos pueden ver la lun.

Saludos.

sbdonosti
Enthusiast
Enthusiast

buenas tardes Kailess1,

Gracias por tu aportacion, pero como comento un poco mas arriba el culpable era el firewall del host, lo he dejado todo abierto y veo perfectamente la lun

saludos, gracias de todas formas por tu interes

0 Kudos