Alfons1714
Contributor
Contributor

en host HP de dos lun una no la veo en vsphere.

Jump to solution

Hola.

El escenario: Un servidor HP DL 385 g6 con una controladora Raid con dos bahias para 4 discos cada una. Es antiguo pero solo está para réplicas de veeam.

En la información de la iLO aparece que el firmware del Backplane 1 es 1.16 i el del backplane2 es 1.14.

Estaba instalado esxi 5.1 y veía perfectamente los dos raid. Los dos eran raid10.  He actualizado a 5.5 para ser coherente con el otro servidor (el principal).
En el servidor he creado  de nuevo los raid pero esta vez  raid5. En el servidor los dos raid aparecen como correctos.

Desde vSphere client , accediendo al vcenter  intento crear los datastores añadiendo las LUN.
Solo veo la que está en el backplane2. La otra (en el backplane1)  no la veo y no la puedo añadir como datastore.

¿Qué puede estar sucediendo?

Gracias y saludos
Alfons

1 Solution

Accepted Solutions
e_espinel
Expert
Expert

Hola.

Si son abreviatura de HP y sobre SUM esta incluido en el ISO.

Te recomiendo hacer la actualización del Firmware de la Smart Array  directamente en el ESXi host mediante SSH.

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.

View solution in original post

12 Replies
e_espinel
Expert
Expert

Hola.

Lo recomendable en estos caso es instalar el VMware vSphere desde el custom ISO del fabricante en este caso HP

lo puedes obtener en el siguiente link con un usuario simple en My VMware

link: https://my.vmware.com/group/vmware/downloads/details?downloadGroup=HPE-ESXI-5.5.0U3A-GA&productId=35...

Despues se lo debería parchas al ultimo nivel disponible para la versión 5.5

Siempre es recomendable actualizar los Firmware del Server en este caso HP tiene  los ISO de actualizaciones Service Pack for ProLiant (SPP), debería ser 2014 o 2012

Una verificación que se puede hacer desde la CLI (habilitando SSH en el host) y conectándose por putty o telnet al host, siempre que se instalo con la

ISO de HP es utilizar el STOCLI (también se puede instalar por separado esta utileria que es del fabricante de la tarjeta)

Se requiere ingresar al directorio cd /opt/lsi/storcli

luego ejecutar le siguiente comando   ./storcli /c0/dall show   que nos permite observar todos los Arrays y Volumennes del host

pastedImage_7.png

Si vemos todo lo que esta configurado en el Hardware correctamente, el problema estaría en el VMware vSphere habría que parcharlo, y/o verificar la versión del  VMware client que estamos usando para conectarnos.

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
Alfons1714
Contributor
Contributor

Hola. Gracias por responder.

Instalé desde una iso del fabricante. Realmente una revisión posterior a la que me has indicado.

El el caso del firmware, mira que pongo que el raid que me funciona tiene un firmware anterior al que no me funciona.
1.4 el que si veo contra 1.6 el que no. Además , en el gestor de raids del servidor, me los marca los dos como correctos.

Por otra parte, accediendo por ssh no encuentro el directorio que me comentas.

Dentro de /opt  solo tengo  hp, hpe, smartstorageadmin  y vmware. No aparece lsi.

En smartstoreadmin hay un directorio ssacli con  uno bin  y que tiene un ejectuable llamado ssacli.

Parece que es el equivalente a lo que me indicas. Al ejecutarlo con los mismos modificadores que me apuntabas me da error "invalid commands).

Lo he ejecutado con -h i ahora he de digerir eso.  No es fácil

Lo que extraña es que una matriz la vea y la otra no. Y la que no es la que tiene el firmware más nuevo.
El servidor principal también es ESXi 5.5.0 y no tiene ningún problema.
El cliente de vSphere es  5.50 y el vCenter también.

Voy a seguir viendo el comando ssacli a ver si lo llego e entender bien.

Un saludo cordial

Alfons

0 Kudos
Alfons1714
Contributor
Contributor

Añado:haciendo :

/opt/smartstorageadmin/ssacli/bin/ssacli controller all show config

Me muestra las dos Arrays. La que veo en el cliente y la que no.

*************************************************************

/opt/smartstorageadmin/ssacli/bin # /opt/smartstorageadmin/ssacli/bin/ssacli controller all show config

Smart Array P410 in Slot 3                (sn: PACCR9SYDQXD  )


   Port Name: 1I

   Port Name: 2I


   Internal Drive Cage at Port 1I, Box 1, OK



   Internal Drive Cage at Port 2I, Box 1, OK


   Array A (SAS, Unused Space: 0  MB)

      logicaldrive 1 (838.1 GB, RAID 5, OK)

      physicaldrive 1I:1:1 (port 1I:box 1:bay 1, SAS HDD, 300 GB, OK)
      physicaldrive 1I:1:2 (port 1I:box 1:bay 2, SAS HDD, 300 GB, OK)
      physicaldrive 1I:1:3 (port 1I:box 1:bay 3, SAS HDD, 300 GB, OK)
      physicaldrive 1I:1:4 (port 1I:box 1:bay 4, SAS HDD, 300 GB, OK)


   Array B (SAS, Unused Space: 0  MB)

      logicaldrive 2 (1.6 TB, RAID 5, OK)

      physicaldrive 2I:1:5 (port 2I:box 1:bay 5, SAS HDD, 600 GB, OK)
      physicaldrive 2I:1:6 (port 2I:box 1:bay 6, SAS HDD, 600 GB, OK)
      physicaldrive 2I:1:7 (port 2I:box 1:bay 7, SAS HDD, 600 GB, OK)
      physicaldrive 2I:1:8 (port 2I:box 1:bay 8, SAS HDD, 600 GB, OK)

   SEP (Vendor ID PMCSIERA, Model  SRC 8x6G) 250  (WWID: 500143800646DFDF)
**********************************************************************

La que no ve el cliente es la primera. La A.

0 Kudos
e_espinel
Expert
Expert

Hola.

Excelente y buena iniciativa, el ssacli (HPE Storage Controller Management/ HP Smart Array CLI) La herramienta es compatible con la mayoría de los controladores SmartArray de HPE de los últimos 10 a 15 años.

Entonces, tenemos 2 Arrays configurados que los podemos observar por CLI, pero no los vemos por el VMware client, aunque en general siempre es recomendable actualizar los Firmware, el problema creo que esta en la versión del driver de la controller de disco que se esta usando.

Puedes indicar el Build del VMware vSphere, al igual que el Firmware y el driver  de la controller que tienes instalado.

Cuando indicas que instalaste el VMware vSphere con ISO del fabricante te refieres a VMware o a HP ?

Con el siguiente comando podrías ver el detalle de la controller incluido la version del Firmware

/opt/hp/hpssacli/bin/hpssacli ctrl all show detail

link: HPE Smart Array CLI commands on ESXi | Kalle's playground

Con este comando listamos los dispositivos SCSI del host

# esxcfg-scsidevs -a

identificamos la controller de discos (Smart Array P410) y ejecutamos le siguiente comando para ver la versión del driver

# vmkload_mod -s  nombretarjeta |grep Version

Detalles adicionales

En VMware vSphere 5.1 las versiones del driver era:

Versión:5.0.0.118-1 (21 Apr 2016) 

   Versión:5.0.0.116-1 (13 Nov 2015) 

   Versión:5.0.0.114-1 (17 Dec 2015) 

   Versión:5.0.0.106-1 (15 Jun 2015) 

   Versión:5.0.0.84-1 (30 Mar 2015) 

   Versión:5.0.0.74-1 (1 Oct 2014) 

   Versión:5.0.0.60-1 (11 Jun 2014) 

   Versión:5.0.0-58.1 (18 Feb 2014) 

   Versión:5.0.0-44.1 (7 Nov 2013) 

   Versión:5.0.0-40.1 (19 Feb 2013) 

   Versión:5.0.0-28.0 (14 Sep 2012)

En  VMware vSphere 5.5 las versiones del driver era

Versión:5.5.0.128-1 (15 Sep 2017) 

   Versión:5.5.0.124-1 (9 Dec 2016) 

   Versión:5.5.0.120-1 (24 Oct 2016) 

   Versión:5.5.0.118-1 (21 Apr 2016) 

   Versión:5.5.0.116-1 (13 Nov 2015) 

   Versión:5.5.0.114-1 (17 Dec 2015) 

   Versión:5.5.0.106-1 (15 Jun 2015) 

   Versión:5.5.0.84-1 (30 Mar 2015) 

   Versión:5.5.0.74-1 (1 Oct 2014) 

   Versión:5.5.0.60-1 (11 Jun 2014) 

   Versión:5.5.0-58.1 (18 Feb 2014) 

   Versión:5.5.0.50-1 (7 Nov 2013)

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
Alfons1714
Contributor
Contributor

/opt/smartstorageadmin/ssacli/bin # ./ssacli ctrl all show detail

Smart Array P410 in Slot 3

   Bus Interface: PCI

   Slot: 3

   Serial Number: PACCR9SYDQXD

   Cache Serial Number: PACCQ9SYIKFN

   Controller Status: OK

   Hardware Revision: C

   Firmware Version: 2.50-0

   Rebuild Priority: Medium

   Expand Priority: Medium

   Surface Scan Delay: 15 secs

   Surface Scan Mode: Idle

   Parallel Surface Scan Supported: No

   Queue Depth: Automatic

   Monitor and Performance Delay: 60  min

   Elevator Sort: Enabled

   Degraded Performance Optimization: Disabled

   Inconsistency Repair Policy: Disabled

   Wait for Cache Room: Disabled

   Surface Analysis Inconsistency Notification: Disabled

   Post Prompt Timeout: 0 secs

   Cache Board Present: True

   Cache Status: OK

   Cache Ratio: 100% Read / 0% Write

   Drive Write Cache: Disabled

   Total Cache Size: 256 MB

   Total Cache Memory Available: 144 MB

   No-Battery Write Cache: Disabled

   SATA NCQ Supported: True

   Number of Ports: 2 Internal only

   Driver Name: HPE HPSA

   Driver Version: 5.5.0.124-1OEM

   PCI Address (Domain:Bus:Device.Function): 0000:48:00.0

   Host Serial Number: CZ20101YWS

   Sanitize Erase Supported: False

   Primary Boot Volume: None

   Secondary Boot Volume: None

  

/opt/smartstorageadmin/ssacli/bin # esxcfg-scsidevs -a

vmhba38 sata_svw          link-n/a  sata.vmhba38                            (0:1:14.0) ServerWorks BCM5785 [HT1000] SATA (Native SATA Mode)

vmhba39 sata_svw          link-n/a  sata.vmhba39                            (0:1:14.0) ServerWorks BCM5785 [HT1000] SATA (Native SATA Mode)

vmhba0  sata_svw          link-n/a  sata.vmhba0                             (0:1:14.0) ServerWorks BCM5785 [HT1000] SATA (Native SATA Mode)

vmhba1  hpsa              link-n/a  sas.500143800646dfd0                    (0:72:0.0) Hewlett Packard Enterprise Smart Array P410

vmhba32 usb-storage       link-n/a  usb.vmhba32                             () USB                         

vmhba33 bnx2i             unbound   iscsi.vmhba33                           QLogic 5709 1 Gigabit Ethernet Adapter

vmhba34 bnx2i             unbound   iscsi.vmhba34                           QLogic 5709 1 Gigabit Ethernet Adapter

vmhba35 bnx2i             unbound   iscsi.vmhba35                           QLogic 5709 1 Gigabit Ethernet Adapter

vmhba36 bnx2i             unbound   iscsi.vmhba36                           QLogic 5709 1 Gigabit Ethernet Adapter

vmhba37 sata_svw          link-n/a  sata.vmhba37                            (0:1:14.0) ServerWorks BCM5785 [HT1000] SATA (Native SATA Mode)

El servidor tiene instalado ESXi 5.5.0 3568722 del 9  diciembre de 2016.

Es decir la  5.5.0.124-1 (driver)

Lo curioso es que con  ESXi 5.1  veia la matriz perfectamente.

0 Kudos
Alfons1714
Contributor
Contributor

La iso fue descargada de vmware, si no recuerdo mal.

El firmware, te refieres al de la controladora Raid?  Tiene firmware 1.4 para el "backplane" que tiene la matriz que se ve  y 1.6 para el que tiene la matriz que no se ve.

0 Kudos
Alfons1714
Contributor
Contributor

opt/smartstorageadmin/ssacli/bin # vmkload_mod -s  hpsa |grep Version
Version: Version 5.5.0.124-1OEM, Build: 1331820, Interface: 9.2 Built on: Nov 17 2016

0 Kudos
e_espinel
Expert
Expert

Hola.

Lo que podemos probar es actualizar el driver a su ultima versión 5.5.0.128-1(15 Sep 2017)

los paso son los de costumbre:

1. obtener el file.zip

2. copiar el file.zip al ESXi host (con pscp (utileria de Putty) o WINSCP) en un volumen interno puede ser en el directorio /tmp o crear uno dentro de /tmp (eje /tmp/update)

3.  apagar todas las VM y poner el ESXi en modo mantenimiento

4.  ingresar al host ESXi  con user root por ssh

5. ejecutar el siguiente comando

   # esxcli software vib update -d {OFFLINE_BUNDLE}

update - cuando ya existe el driver y lo queremos actualizar

install  cuando se quiere instalar un paquete nuevo

offline_Bundle se refiere al file.zip pero debe incluir su full path (hubicacion completa/file.zip)

6  Reiniciar el Host

7. sacar del modo mantenimiento al ESXi host.

Adjunto linkdonde obtener el driver:

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_fa3645af4f6e447aaaa1273ab3#tab2

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
e_espinel
Expert
Expert

Hola.

Con respecto al Firmware 2.50 de la Smart Array P410 es muy bajo y se tendría que buscar un CD muy viejo de SPP

Si continua el problema se tendrá que intnetar actualizar el firmware.

Dejo un link donde obtener el  FW y las instrucciones para ejecutarlo , el FW es el mismo para algunos modelos de la tarjeta.

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX-d2c320b9a12e4671a9d213bdb7#tab3

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
Alfons1714
Contributor
Contributor

Hola

Supongo que SPP es "Service Pack Proliant". Supongo que hp sum es una aplicación que se encuentra en SPP

Voy a intentar hacerlo todo en remoto este fin de semana. La verdad es que no sigo muy bien las instrucciones dd HP para hacerlo "remote on line". Es nuevo para mí.

Primero actualizaré a 5.5.0.128 y  si no solventa, intentaréactualizar el driver de la tarjeta.
Saludos

0 Kudos
e_espinel
Expert
Expert

Hola.

Si son abreviatura de HP y sobre SUM esta incluido en el ISO.

Te recomiendo hacer la actualización del Firmware de la Smart Array  directamente en el ESXi host mediante SSH.

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.

View solution in original post

Alfons1714
Contributor
Contributor

Hola.

Bueno, he aprendido algunas buenas lecciones gracias a tí.

Actualicé firmware y driver. Y segui  los enlaces que me pusiste..

Ahora me funciona todo.

Un millón de gracias !!!!

Saludos y hasta pronto !

0 Kudos